HDU1896-Stones

234 篇文章 1 订阅

Stones

Time Limit : 5000/3000ms (Java/Other)   Memory Limit : 65535/32768K (Java/Other)
Total Submission(s) : 47   Accepted Submission(s) : 37
Font: Times New Roman | Verdana | Georgia
Font Size:  

Problem Description

Because of the wrong status of the bicycle, Sempr begin to walk east to west every morning and walk back every evening. Walking may cause a little tired, so Sempr always play some games this time. 
There are many stones on the road, when he meet a stone, he will throw it ahead as far as possible if it is the odd stone he meet, or leave it where it was if it is the even stone. Now give you some informations about the stones on the road, you are to tell me the distance from the start point to the farthest stone after Sempr walk by. Please pay attention that if two or more stones stay at the same position, you will meet the larger one(the one with the smallest Di, as described in the Input) first. 

Input

In the first line, there is an Integer T(1<=T<=10), which means the test cases in the input file. Then followed by T test cases. 
For each test case, I will give you an Integer N(0<N<=100,000) in the first line, which means the number of stones on the road. Then followed by N lines and there are two integers Pi(0<=Pi<=100,000) and Di(0<=Di<=1,000) in the line, which means the position of the i-th stone and how far Sempr can throw it.

Output

Just output one line for one test case, as described in the Description.

Sample Input

2
2
1 5
2 4
2
1 5
6 6

Sample Output

11
12

Author

Sempr|CrazyBird|hust07p43

Source

HDU 2008-4 Programming Contest

题意:路上有很多石头,当你遇到奇数序列的石头就把他向前仍,偶数的不动他,如果两个石头一起,先考虑扔的比较近的石头扔,这样一直下去,直到前面所有的石头都不可以仍了为止,求最远的石头距离起点多少

解题思路:优先队列


#include <iostream>
#include <cstdio>
#include <string>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <queue>
#include <vector>
#include <set>
#include <bitset>
#include <stack>
#include <map>
#include <climits>
#include <functional>

using namespace std;

#define LL long long
const int INF=0x3f3f3f3f;

struct node
{
    int p,d;
    bool friend operator <(node a,node b)
    {
        if(a.p==b.p) return b.d<a.d;
        return b.p<a.p;
    }
}temp;

int main()
{
    int t,n,flag,ans;
    scanf("%d",&t);
    while(t--)
    {
        priority_queue<node>q;
        scanf("%d",&n);
        for(int i=0;i<n;i++)
        {
            scanf("%d %d",&temp.p,&temp.d);
            q.push(temp);
        }
        flag=1;ans=0;
        while(!q.empty())
        {
            temp=q.top();
            q.pop();
            ans=max(ans,temp.p);
            if(flag)
            {
                temp.p=temp.p+temp.d;
                q.push(temp);
            }
            flag=!flag;
        }
        printf("%d\n",ans);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值