-
You are my brother
- 时间限制: 1000 ms 内存限制: 131072 K
- 问题描述
-
Little A gets to know a new friend, Little B, recently. One day, they realize that they are family 500 years ago. Now, Little A wants to know whether Little B is his elder, younger or brother.
- 输入
-
There are multiple test cases.
For each test case, the first line has a single integer, n (n<=1000). The next n lines have two integers a and b (1<=a,b<=2000) each, indicating b is the father of a. One person has exactly one father, of course. Little A is numbered 1 and Little B is numbered 2.
Proceed to the end of file. - 输出
-
For each test case, if Little B is Little A’s younger, print “You are my younger”. Otherwise, if Little B is Little A’s elder, print “You are my elder”. Otherwise, print “You are my brother”. The output for each test case occupied exactly one line.
- 样例输入
-
5 1 3 2 4 3 5 4 6 5 6 6 1 3 2 4 3 5 4 6 5 7 6 7
- 样例输出
-
You are my elder You are my brother
- 提示
-
无
- 来源
-
辽宁省赛2010
题意:给出一张家谱,问1号和2号谁的年龄大
解题思路:dfs
#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <map>
#include <set>
#include <vector>
#include <algorithm>
#include <cmath>
#include <queue>
#include <stack>
#include <functional>
#include <climits>
using namespace std;
#define LL long long
const int INF=0x3f3f3f3f;
int visit[20005];
int f[20005];
int n,a,b,k,kk;
void dfs(int x,int y)
{
if(f[x]==x) {k=y;return ;}
dfs(f[x],y+1);
}
void dfs1(int x,int y)
{
if(f[x]==x) {kk=y;return ;}
dfs1(f[x],y+1);
}
int main()
{
while(~scanf("%d",&n))
{
for(int i=0;i<20000;i++) f[i]=i;
for(int i=1;i<=n;i++)
{
scanf("%d%d",&a,&b);
f[a]=b;
}
dfs(1,1);
dfs1(2,1);
if(kk==k) printf("You are my brother\n");
else if(kk>k) printf("You are my younger\n");
else printf("You are my elder\n");
}
return 0;
}