POJ3616-Milking Time

Milking Time
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9571 Accepted: 3972

Description

Bessie is such a hard-working cow. In fact, she is so focused on maximizing her productivity that she decides to schedule her next N (1 ≤ N ≤ 1,000,000) hours (conveniently labeled 0..N-1) so that she produces as much milk as possible.

Farmer John has a list of M (1 ≤ M ≤ 1,000) possibly overlapping intervals in which he is available for milking. Each interval i has a starting hour (0 ≤ starting_houri ≤ N), an ending hour (starting_houri < ending_houri ≤ N), and a corresponding efficiency (1 ≤ efficiencyi ≤ 1,000,000) which indicates how many gallons of milk that he can get out of Bessie in that interval. Farmer John starts and stops milking at the beginning of the starting hour and ending hour, respectively. When being milked, Bessie must be milked through an entire interval.

Even Bessie has her limitations, though. After being milked during any interval, she must rest R (1 ≤ R ≤ N) hours before she can start milking again. Given Farmer Johns list of intervals, determine the maximum amount of milk that Bessie can produce in the N hours.

Input

* Line 1: Three space-separated integers: NM, and R
* Lines 2..M+1: Line i+1 describes FJ's ith milking interval withthree space-separated integers: starting_houri , ending_houri , and efficiencyi

Output

* Line 1: The maximum number of gallons of milk that Bessie can product in the N hours

Sample Input

12 4 2
1 2 8
10 12 19
3 6 24
7 10 31

Sample Output

43

Source


题意:一个人在0~N时间段产奶。他有M个时间段可以挤奶,时间段f, t内他能挤到的牛奶量e。奶牛产奶后需要休息R小时才能继续下一次产奶,求他最大的挤奶量

题解思路:先对挤奶时间按照结束时间从小到大排序,然后dp,但是注意最后一个时间段不一定是最后一次挤奶,所以要对每个挤奶时间取个最大值


#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <cmath>
#include <map>
#include <set>
#include <stack>
#include <queue>
#include <vector>
#include <bitset>
#include <functional>

using namespace std;

#define LL long long
const int INF = 0x3f3f3f3f;

int n,m,t,dp[1005];
struct node
{
    int x,l,r;
}a[1005];

bool cmp(node a,node b)
{
    return a.r<b.r;
}

int main()
{
    while(~scanf("%d%d%d",&n,&m,&t))
    {
        memset(dp,0,sizeof dp);
        for(int i=1;i<=m;i++) scanf("%d%d%d",&a[i].l,&a[i].r,&a[i].x);
        sort(a+1,a+1+m,cmp);
        a[0].r=-INF;
        for(int i=1;i<=m;i++)
            for(int j=0;j<i;j++)
                if(a[i].l>=a[j].r+t) dp[i]=max(dp[i],dp[j]+a[i].x);
        int ma=0;
        for(int i=1;i<=m;i++)
            ma=max(ma,dp[i]);
        printf("%d\n",ma);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值