POJ3181-Dollar Dayz

Dollar Dayz
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7237 Accepted: 2704

Description

Farmer John goes to Dollar Days at The Cow Store and discovers an unlimited number of tools on sale. During his first visit, the tools are selling variously for $1, $2, and $3. Farmer John has exactly $5 to spend. He can buy 5 tools at $1 each or 1 tool at $3 and an additional 1 tool at $2. Of course, there are other combinations for a total of 5 different ways FJ can spend all his money on tools. Here they are: 

        1 @ US$3 + 1 @ US$2

        1 @ US$3 + 2 @ US$1

        1 @ US$2 + 3 @ US$1

        2 @ US$2 + 1 @ US$1

        5 @ US$1
Write a program than will compute the number of ways FJ can spend N dollars (1 <= N <= 1000) at The Cow Store for tools on sale with a cost of $1..$K (1 <= K <= 100).

Input

A single line with two space-separated integers: N and K.

Output

A single line with a single integer that is the number of unique ways FJ can spend his money.

Sample Input

5 3

Sample Output

5

Source


题意:一个人有n元钱,市场上有价值1……k的商品无限个,求所有的花钱方案

解题思路:完全背包,不过由于这题答案特别大,超了long long int,所以要用来个数组来保存,一个用来保存溢出的


#include <iostream>  
#include <cstdio>  
#include <cstring>  
#include <string>  
#include <algorithm>  
#include <cmath>  
#include <map>  
#include <cmath>  
#include <set>  
#include <stack>  
#include <queue>  
#include <vector>  
#include <bitset>  
#include <functional>  

using namespace std;

#define LL long long  
const int INF = 0x3f3f3f3f;
const LL mod = 1000000000000000000;

int n, m;
LL dp[1009],a[1009];

int main()
{
	while (~scanf("%d%d", &n, &m))
	{
		memset(dp, 0, sizeof dp);
		memset(a, 0, sizeof a);
		dp[0] = 1;
		for (int i = 1; i <= m; i++)
			for (int j = i; j <= n; j++)
			{
				dp[j] = dp[j] + dp[j - i];
				a[j] = a[j] + a[j - i] + dp[j] / mod;
				dp[j] %= mod;
			}
		if (a[n]) printf("%lld", a[n]);
		printf("%lld\n", dp[n]);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值