POJ2566-Bound Found

Bound Found
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 4057 Accepted: 1250 Special Judge

Description

Signals of most probably extra-terrestrial origin have been received and digitalized by The Aeronautic and Space Administration (that must be going through a defiant phase: "But I want to use feet, not meters!"). Each signal seems to come in two parts: a sequence of n integer values and a non-negative integer t. We'll not go into details, but researchers found out that a signal encodes two integer values. These can be found as the lower and upper bound of a subrange of the sequence whose absolute value of its sum is closest to t. 

You are given the sequence of n integers and the non-negative target t. You are to find a non-empty range of the sequence (i.e. a continuous subsequence) and output its lower index l and its upper index u. The absolute value of the sum of the values of the sequence from the l-th to the u-th element (inclusive) must be at least as close to t as the absolute value of the sum of any other non-empty range.

Input

The input file contains several test cases. Each test case starts with two numbers n and k. Input is terminated by n=k=0. Otherwise, 1<=n<=100000 and there follow n integers with absolute values <=10000 which constitute the sequence. Then follow k queries for this sequence. Each query is a target t with 0<=t<=1000000000.

Output

For each query output 3 numbers on a line: some closest absolute sum and the lower and upper indices of some range where this absolute sum is achieved. Possible indices start with 1 and go up to n.

Sample Input

5 1
-10 -5 0 5 10
3
10 2
-9 8 -7 6 -5 4 -3 2 -1 0
5 11
15 2
-1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1
15 100
0 0

Sample Output

5 4 4
5 2 8
9 1 1
15 1 15
15 1 15

Source


题意:给出有n个数的一个序列,有q次询问,每次询问哪一段区间的绝对值最接近t

解题思路:这题不能用一般的尺取法来做,因为只有数列保证单调性才能用尺取法。可以先求一下前缀和,然后把前缀和从小到大进行排序,由于abs(sum[i]-sum[j])=abs(sum[j]-sum[i]),可以忽视数列前缀和的前后关系。此时,sum[r]-sum[l]有单调性。因此可以先比较当前sum[r]-sum[l]与t的差,并更新答案。果当前sum[r]-sum[l]<t,说明和还可以更大,r++。同理,如果sum[r]-sum[l]>t,说明和还可以更小,l++。如果sum[r]-sum[l]=t,必定是最小答案。由于序列不能为空,即l!=r,如果l==r则r++


#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <queue>
#include <stack>
#include <cmath>
#include <map>
#include <bitset>
#include <set>
#include <vector>
#include <functional>

using namespace std;

#define LL long long
const int INF = 0x3f3f3f3f;

int n, q, k, ansl, ansr, mi,ans;
int a[100009];
struct node
{
	int id, sum;
}x[100009];

bool cmp(node a, node b)
{
	return a.sum < b.sum;
}

int main()
{
	while (~scanf("%d%d", &n, &q) && (n + q))
	{
		x[0].id = 0, x[0].sum = 0;
		for (int i = 1; i <= n; i++) scanf("%d", &a[i]), x[i].id = i, x[i].sum = x[i - 1].sum + a[i];
		sort(x, x + n+1, cmp);
		while (q--)
		{
			scanf("%d", &k);
			mi = INF;
			int l = 0, r = 1;
			while (mi != 0 && l <= n&&r <= n)
			{
				int temp = x[r].sum - x[l].sum;
				if (abs(temp - k) < mi)
				{
					mi = abs(temp - k);
					ans = temp;
					ansr = max(x[r].id, x[l].id);
					ansl = min(x[r].id, x[l].id) + 1;
				}
				if (temp > k) l++;
				else if(temp<k) r++;
				else break;
				if (l == r) r++;
			}
			printf("%d %d %d\n", ans, ansl, ansr);
		}
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值