PAT (Advanced Level) Practise 1061 Dating (20)

1061. Dating (20)

时间限制
150 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Sherlock Holmes received a note with some strange strings: "Let's date! 3485djDkxh4hhGE 2984akDfkkkkggEdsb s&hgsfdk d&Hyscvnm". It took him only a minute to figure out that those strange strings are actually referring to the coded time "Thursday 14:04" -- since the first common capital English letter (case sensitive) shared by the first two strings is the 4th capital letter 'D', representing the 4th day in a week; the second common character is the 5th capital letter 'E', representing the 14th hour (hence the hours from 0 to 23 in a day are represented by the numbers from 0 to 9 and the capital letters from A to N, respectively); and the English letter shared by the last two strings is 's' at the 4th position, representing the 4th minute. Now given two pairs of strings, you are supposed to help Sherlock decode the dating time.

Input Specification:

Each input file contains one test case. Each case gives 4 non-empty strings of no more than 60 characters without white space in 4 lines.

Output Specification:

For each test case, print the decoded time in one line, in the format "DAY HH:MM", where "DAY" is a 3-character abbreviation for the days in a week -- that is, "MON" for Monday, "TUE" for Tuesday, "WED" for Wednesday, "THU" for Thursday, "FRI" for Friday, "SAT" for Saturday, and "SUN" for Sunday. It is guaranteed that the result is unique for each case.

Sample Input:
3485djDkxh4hhGE 
2984akDfkkkkggEdsb 
s&hgsfdk 
d&Hyscvnm
Sample Output:
THU 14:04

题意:输入四个字符串。找出一二两个字符串中第一个相同的大写字母(注意是逐个比较,即对应的位置相同),字母的范围是‘A’ ~ ‘G’。找出一二两个字符串中第二个相同的大写字母或者数字,范围是’A‘~'N' 或者 '0' ~ '9'。 找出三四两个字符串中第一个相同的字母(不要求大写)


#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <cmath>
#include <map>
#include <set>
#include <stack>
#include <queue>
#include <vector>
#include <bitset>

using namespace std;

#define LL long long
const int INF = 0x3f3f3f3f;

char a[100], b[100];
char x[7][10] = { "MON", "TUE", "WED", "THU", "FRI", "SAT", "SUN" };

int main()
{
	while (~scanf("%s%s", a, b))
	{
		int day = -1, hour, minute;
		for (int i = 0; a[i] && b[i]; i++)
		{
			if (a[i] == b[i])
			{
				if (day == -1 && a[i] >= 'A'&&a[i] <= 'G') day = a[i] - 'A';
				else if (day >= 0)
				{
					if (a[i] >= 'A'&&a[i] <= 'N') { hour = a[i] - 'A' + 10; break; }
					else if (a[i] >= '0'&&a[i] <= '9') { hour = a[i] - '0'; break; }
				}
			}
		}
		scanf("%s%s", a, b);
		for (int i = 0; a[i] && b[i]; i++)
		{
			if (a[i] == b[i] && (a[i] >= 'a'&&a[i] <= 'z' || a[i] >= 'A'&&a[i] <= 'Z')) minute = i;
		}
		printf("%s %02d:%02d\n", x[day], hour, minute);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值