HDU5858-Hard problem

Hard problem

                                                                      Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
                                                                                                Total Submission(s): 705    Accepted Submission(s): 454


Problem Description
cjj is fun with math problem. One day he found a Olympic Mathematics problem for primary school students. It is too difficult for cjj. Can you solve it?


Give you the side length of the square L, you need to calculate the shaded area in the picture.

The full circle is the inscribed circle of the square, and the center of two quarter circle is the vertex of square, and its radius is the length of the square.
 

Input
The first line contains a integer T(1<=T<=10000), means the number of the test case. Each case contains one line with integer l(1<=l<=10000).
 

Output
For each test case, print one line, the shade area in the picture. The answer is round to two digit.
 

Sample Input
  
  
1 1
 

Sample Output
  
  
0.29
 

Author
BUPT
 

Source
 

Recommend
wange2014
 


题意:给你图中正方形的边长,求出图中阴影面积的大小

解题思路:添加如下辅助线即可

这里写图片描述



#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <map>
#include <cmath>
#include <set>
#include <stack>
#include <queue>
#include <vector>
#include <bitset>
#include <functional>

using namespace std;

#define LL long long
const int INF = 0x3f3f3f3f;
const double pi = acos(-1.0);

int main()
{
	int t;
	double l;
	scanf("%d", &t);
	while (t--)
	{
		scanf("%lf", &l);
		double x1 = acos(5 * l*l / 4 / (sqrt(2)*l*l));
		double x2 = acos(-l*l / 4 / (sqrt(2) / 2 * l*l));
		double sum1 = l*l / 8 * (2 * pi - x2 * 2);
		double sum2 = l*l*x1 - l*l / sqrt(2)*sin(x1);
		printf("%.2lf\n", 2 * (sum1 - sum2));
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值