POJ3294-Life Forms

Life Forms
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 16301 Accepted: 4795

Description

You may have wondered why most extraterrestrial life forms resemble humans, differing by superficial traits such as height, colour, wrinkles, ears, eyebrows and the like. A few bear no human resemblance; these typically have geometric or amorphous shapes like cubes, oil slicks or clouds of dust.

The answer is given in the 146th episode of Star Trek - The Next Generation, titled The Chase. It turns out that in the vast majority of the quadrant's life forms ended up with a large fragment of common DNA.

Given the DNA sequences of several life forms represented as strings of letters, you are to find the longest substring that is shared by more than half of them.

Input

Standard input contains several test cases. Each test case begins with 1 ≤ n ≤ 100, the number of life forms. n lines follow; each contains a string of lower case letters representing the DNA sequence of a life form. Each DNA sequence contains at least one and not more than 1000 letters. A line containing 0 follows the last test case.

Output

For each test case, output the longest string or strings shared by more than half of the life forms. If there are many, output all of them in alphabetical order. If there is no solution with at least one letter, output "?". Leave an empty line between test cases.

Sample Input

3
abcdefg
bcdefgh
cdefghi
3
xxx
yyy
zzz
0

Sample Output

bcdefg
cdefgh

?

Source



题意:给定n个字符串,求出现在不小于k/2个字符串中的最长子串

解题思路:后缀数组,将n个字符串连接起来,然后用没出现过的字符连接,后缀数组+二分长度即可


#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <map>
#include <set>
#include <stack>
#include <queue>
#include <vector>
#include <bitset>
#include <functional>

using namespace std;

#define LL long long
const int INF = 0x3f3f3f3f;
const int N = 200010;

int k;

struct Sa
{
	char ch[N];
	int s[N], vis[105], ans[N];
	int rk[2][N], sa[N], h[N], w[N], now, n, len[N];
	int rmq[N][20], lg[N], bel[N];

	void GetS()
	{
		n = 0;
		for (int i = 1; i <= k; i++)
		{
			scanf("%s", ch);
			for (int j = 0; ch[j]; j++) s[++n] = ch[j], bel[n] = i;
			s[++n] = 'z' + i;
			len[i] = n;
		}
	}

	void getsa(int z, int &m)
	{
		int x = now, y = now ^= 1;
		for (int i = 1; i <= z; i++) rk[y][i] = n - i + 1;
		for (int i = 1, j = z; i <= n; i++)
			if (sa[i] > z) rk[y][++j] = sa[i] - z;
		for (int i = 1; i <= m; i++) w[i] = 0;
		for (int i = 1; i <= n; i++) w[rk[x][rk[y][i]]]++;
		for (int i = 1; i <= m; i++) w[i] += w[i - 1];
		for (int i = n; i >= 1; i--) sa[w[rk[x][rk[y][i]]]--] = rk[y][i];
		for (int i = m = 1; i <= n; i++)
		{
			int *a = rk[x] + sa[i], *b = rk[x] + sa[i - 1];
			rk[y][sa[i]] = *a == *b&&*(a + z) == *(b + z) ? m - 1 : m++;
		}
	}

	void getsa(int m)
	{
		now = rk[1][0] = sa[0] = s[0] = 0;
		for (int i = 1; i <= m; i++) w[i] = 0;
		for (int i = 1; i <= n; i++) w[s[i]]++;
		for (int i = 1; i <= m; i++) rk[1][i] = rk[1][i - 1] + (bool)w[i];
		for (int i = 1; i <= m; i++) w[i] += w[i - 1];
		for (int i = 1; i <= n; i++) rk[0][i] = rk[1][s[i]];
		for (int i = 1; i <= n; i++) sa[w[s[i]]--] = i;
		rk[1][n + 1] = rk[0][n + 1] = 0;
		for (int x = 1, y = rk[1][m]; x <= n&&y <= n; x <<= 1) getsa(x, y);
		for (int i = 1, j = 0; i <= n; h[rk[now][i++]] = j ? j-- : j)
		{
			if (rk[now][i] == 1) continue;
			int k = n - max(sa[rk[now][i] - 1], i);
			while (j <= k&&s[sa[rk[now][i] - 1] + j] == s[i + j]) ++j;
		}
	}

	void getrmq()
	{
		h[n + 1] = h[1] = lg[1] = 0;
		for (int i = 2; i <= n; i++)
			rmq[i][0] = h[i], lg[i] = lg[i >> 1] + 1;
		for (int i = 1; (1 << i) <= n; i++)
		{
			for (int j = 2; j <= n; j++)
			{
				if (j + (1 << i) > n + 1) break;
				rmq[j][i] = min(rmq[j][i - 1], rmq[j + (1 << i - 1)][i - 1]);
			}
		}
	}

	int lcp(int x, int y)
	{
		int l = min(rk[now][x], rk[now][y]) + 1, r = max(rk[now][x], rk[now][y]);
		return min(rmq[l][lg[r - l + 1]], rmq[r - (1 << lg[r - l + 1]) + 1][lg[r - l + 1]]);
	}

	bool check(int x)
	{
		memset(vis, 0, sizeof vis);
		int sum = 0, cnt = 0;
		for (int i = 1; i <= n; i++)
		{
			if (h[i] >= x)
			{
				sum += vis[bel[sa[i]]] ^ 1, vis[bel[sa[i]]] = 1;
				sum += vis[bel[sa[i - 1]]] ^ 1, vis[bel[sa[i - 1]]] = 1;
			}
			else
			{
				if (sum > k / 2) ans[++cnt] = sa[i - 1];
				sum = 0;
				memset(vis, 0, sizeof vis);
			}
		}
		if (sum > k / 2) ans[++cnt] = sa[n];
		if (cnt) ans[0] = cnt;
		return cnt;
	}

	void work()
	{
		if (k == 1) { printf("%s\n", ch); return; }
		getsa(300);
		int l = 1, r = n, ans1 = 0;
		while (l <= r)
		{
			int mid = (l + r) >> 1;
			if (check(mid)) l = mid + 1, ans1 = mid;
			else r = mid - 1;
		}
		if (!ans1) { printf("?\n"); return; }
		for (int i = 1; i <= ans[0]; i++)
		{
			for (int j = ans[i]; j < ans[i] + ans1; j++)
				printf("%c", s[j]);
			printf("\n");
		}
	}
}sa;

int main()
{
	int cas = 0;
	while (~scanf("%d", &k) && k)
	{
		if (cas++) printf("\n");
		sa.GetS();
		sa.work();
	}
	return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值