hdu 5328

Problem Killer

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1162    Accepted Submission(s): 449

Problem Description
You are a "Problem Killer", you want to solve many problems. 
Now you have n problems, the i-th problem's difficulty is represented by an integer ai (1≤ai≤109).
For some strange reason, you must choose some integer l and r (1≤l≤r≤n), and solve the problems between the l-th and the r-th, and these problems' difficulties must form an AP (Arithmetic Progression) or a GP (Geometric Progression). 
So how many problems can you solve at most?
You can find the definitions of AP and GP by the following links:
https://en.wikipedia.org/wiki/Arithmetic_progression
https://en.wikipedia.org/wiki/Geometric_progression
 

Input
The first line contains a single integer T, indicating the number of cases. 
For each test case, the first line contains a single integer n, the second line contains n integers a1,a2,⋯,an. 
T≤104,∑n≤106
 
Output
For each test case, output one line with a single integer, representing the answer.

Sample Input
2
5
1 2 3 4 6
10
1 1 1 1 1 1 2 3 4 5
 
Sample Output
4

6

//题意: 求的是形成连续的等差或者等比数列的个数 最大值为多少

#include <stdio.h>
#include <iostream>
#include <cmath>
using namespace std;
int a[1000010];

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n,cnt2,cnt1,ma=0;
        scanf("%d",&n);
        cnt2=cnt1=2;
        for(int i=0;i<n;i++)
        {
            scanf("%d",&a[i]);
            if(i>1)
            {
                if(a[i]-a[i-1]==a[i-1]-a[i-2])
                    cnt1++;
                else
                    cnt1=2;
                if(fabs(1.0*a[i]/a[i-1]-1.0*a[i-1]/a[i-2])<10e-7) //注意形成分数的等比
                    cnt2++;
                else
                    cnt2=2;
            }
            int t=max(cnt1,cnt2);
            if(t>ma)
                ma=t;
        }
        if(n<3)
        {
            printf("%d\n",n);
        }
        else
            printf("%d\n",ma);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值