HDU 5328(Problem Killer-暴力)

Problem Killer

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1535    Accepted Submission(s): 576


Problem Description
You are a "Problem Killer", you want to solve many problems.
Now you have n problems, the i -th problem's difficulty is represented by an integer ai ( 1ai109 ).
For some strange reason, you must choose some integer l and r ( 1lrn ), and solve the problems between the l -th and the r -th, and these problems' difficulties must form an AP (Arithmetic Progression) or a GP (Geometric Progression).
So how many problems can you solve at most?

You can find the definitions of AP and GP by the following links:
https://en.wikipedia.org/wiki/Arithmetic_progression
https://en.wikipedia.org/wiki/Geometric_progression
 

Input
The first line contains a single integer T , indicating the number of cases.
For each test case, the first line contains a single integer n , the second line contains n integers a1,a2,,an .

T104,n106
 

Output
For each test case, output one line with a single integer, representing the answer.
 

Sample Input
  
  
2 5 1 2 3 4 6 10 1 1 1 1 1 1 2 3 4 5
 

Sample Output
  
  
4 6
 

Author
XJZX
 

Source
 

Recommend
wange2014   |   We have carefully selected several similar problems for you:   5416  5415  5414  5413  5412 
 


暴力



#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<algorithm>
#include<functional>
#include<iostream>
#include<cmath>
#include<cctype>
#include<ctime>
using namespace std;
#define For(i,n) for(int i=1;i<=n;i++)
#define Fork(i,k,n) for(int i=k;i<=n;i++)
#define Rep(i,n) for(int i=0;i<n;i++)
#define ForD(i,n) for(int i=n;i;i--)
#define RepD(i,n) for(int i=n;i>=0;i--)
#define Forp(x) for(int p=pre[x];p;p=next[p])
#define Forpiter(x) for(int &p=iter[x];p;p=next[p])  
#define Lson (x<<1)
#define Rson ((x<<1)+1)
#define MEM(a) memset(a,0,sizeof(a));
#define MEMI(a) memset(a,127,sizeof(a));
#define MEMi(a) memset(a,128,sizeof(a));
#define INF (2139062143)
#define F (100000007)
#define MAXN (1000000+10)
typedef long long ll;
ll mul(ll a,ll b){return (a*b)%F;}
ll add(ll a,ll b){return (a+b)%F;}
ll sub(ll a,ll b){return (a-b+llabs(a-b)/F*F+F)%F;}
void upd(ll &a,ll b){a=(a%F+b%F)%F;}
int a[MAXN],b[MAXN];
double c[MAXN];	
int main()
{
//	freopen("B.in","r",stdin);
	
	int n,T;
	cin>>T;
	while (T--)
	{
		cin>>n;
		For(i,n) scanf("%d",&a[i]);
		int ans=min(2,n);
		For(i,n-1) b[i]=a[i]-a[i+1];
		int p=2;
		Fork(i,2,n-1) if (b[i]==b[i-1]) ans=max(ans,++p);else p=2; 
		
		For(i,n-1) c[i]=(double)a[i]/(double)a[i+1];
		p=2;
		Fork(i,2,n-1) if (fabs(c[i]-c[i-1])<1e-8) ans=max(ans,++p);
		else p=2; 
		
		
		
		cout<<ans<<endl;
		
	}
	
	return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值