Hdu-5328 Problem Killer

50 篇文章 0 订阅
Problem Description
You are a "Problem Killer", you want to solve many problems.
Now you have n problems, the i -th problem's difficulty is represented by an integer ai ( 1ai109 ).
For some strange reason, you must choose some integer l and r ( 1lrn ), and solve the problems between the l -th and the r -th, and these problems' difficulties must form an AP (Arithmetic Progression) or a GP (Geometric Progression).
So how many problems can you solve at most?

You can find the definitions of AP and GP by the following links:
https://en.wikipedia.org/wiki/Arithmetic_progression
https://en.wikipedia.org/wiki/Geometric_progression
 

Input
The first line contains a single integer T , indicating the number of cases.
For each test case, the first line contains a single integer n , the second line contains n integers a1,a2,,an .

T104,n106
 

Output
For each test case, output one line with a single integer, representing the answer.
 

Sample Input
  
  
2 5 1 2 3 4 6 10 1 1 1 1 1 1 2 3 4 5
 

Sample Output
  
  
4 6
 

Author
XJZX
 

Source
 

Recommend
wange2014   |   We have carefully selected several similar problems for you:   5701  5700  5699  5698  5697

分析:我的写法挺容易写错的,循环中间break的情况要特殊注意边界。

 
#include <cstdio>
#include <iostream>
#include <algorithm>
using namespace std;
int t,n;
double a[1000006];
int main()
{
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		for(int i = 1;i <= n;i++) scanf("%lf",&a[i]);
		int s = 1,ans = 1;
		while(s < n)
		{
			double d = a[s+1] - a[s];
			int i = s+1; 
			for(;i <= n;i++)
			 if(a[i] - a[i-1] != d) break;
			if(i > n) i--;
			if(a[i] - a[i-1] != d) i--;
			ans = max(ans,i-s+1);
			s = i; 
		}
		s = 1;
		while(s < n)
		{
			double q = a[s+1]/a[s];
			int i = s+1; 
			for(;i <= n;i++)
			 if(a[i]/a[i-1] != q) break;
			if(i > n) i--;
			if(a[i]/a[i-1] != q) i--;
			ans = max(ans,i-s+1);
			s = i; 
		}
		printf("%d\n",ans);
	}
 } 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值