HDU 5455(字符串)

18 篇文章 0 订阅
6 篇文章 0 订阅

Fang Fang

Time Limit: 1500/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 849    Accepted Submission(s): 350


Problem Description
Fang Fang says she wants to be remembered.
I promise her. We define the sequence  F  of strings.
F0 = f",
F1 = ff",
F2 = cff",
Fn = Fn1 + f", for n > 2
Write down a serenade as a lowercase string  S  in a circle, in a loop that never ends.
Spell the serenade using the minimum number of strings in  F , or nothing could be done but put her away in cold wilderness.
 

Input
An positive integer  T , indicating there are  T  test cases.
Following are  T  lines, each line contains an string  S  as introduced above.
The total length of strings for all test cases would not be larger than  106 .
 

Output
The output contains exactly  T  lines.
For each test case, if one can not spell the serenade by using the strings in  F , output  1 . Otherwise, output the minimum number of strings in  F  to split  S according to aforementioned rules. Repetitive strings should be counted repeatedly.
 

Sample Input
  
  
8 ffcfffcffcff cffcfff cffcff cffcf ffffcffcfff cffcfffcffffcfffff cff cffc
 

Sample Output
  
  
Case #1: 3 Case #2: 2 Case #3: 2 Case #4: -1 Case #5: 2 Case #6: 4 Case #7: 1 Case #8: -1
Hint
Shift the string in the first test case, we will get the string "cffffcfffcff" and it can be split into "cffff", "cfff" and "cff".
 
#include <iostream>
#include <stdio.h>
#include <string>
#include <string.h>
#include <cmath>
#include <algorithm>
#include <map>
#include <set>
#include <queue>
using namespace std;
const int inf=(1<<30);
char s[2000000];
int main()
{
    int t,cnt1=1;
    scanf("%d\n",&t);
    while(t--)
    {
        scanf("%s",s);
        int len=strlen(s);
        int t=len;
        int b=len;
        int cnt,mark;
        cnt=mark=0;
        for(int i=0;i<len;i++)
        {
            if(s[i]=='f')
                s[b++]='f';
            if(s[i]=='c')
                break;
        }
        s[b]='\0';
        int len1=strlen(s);
        printf("Case #%d: ",cnt1++);
        if(t*2==b)
        {
            if(len%2==0)
                printf("%d\n",len/2);
            else
                printf("%d\n",len/2+1);
            continue;
        }
        for(int i=0;i<len;i++)
        {
            if(s[i]=='c')
                cnt++;
            if(s[i]!='f'&&s[i]!='c')
                mark=1;
            if(s[i]=='c'&&s[i+1]!='f')
                mark=1;
            if(s[i]=='c'&&s[i+2]!='f')
                mark=1;
            if(s[len-1]=='c'&&s[0]!='f')
                mark=1;
            if(s[len-1]=='c'&&s[1]!='f')
                mark=1;
        }
        if(mark)
            printf("-1\n");
        else
            printf("%d\n",cnt);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值