STL-D

Most crossword puzzle fans are used to anagrams — groups of words with the same letters in different orders — for example OPTS, SPOT, STOP,POTS and POST. Some words however do not have this attribute, no matter how you rearrange their letters, you cannot form another word.Such words are called ananagrams, an example is QUIZ. Obviously such definitions depend on the domain within which we are working; you might think that ATHENE is an ananagram, whereas any chemist would quickly produce ETHANE. One possible domain would be the entire English language, but this could lead to some problems. One could restrict the domain to, say, Music, in which case SCALE becomes a relative ananagram (LACES is not in the same domain) but NOTE is not since it can produce TONE. Write a program that will read in the dictionary of a restricted domain and determine the relative ananagrams. Note that single letter words are, ipso facto, relative ananagrams since they cannot be “rearranged” at all. The dictionary will contain no more than 1000 words.

Input

Input will consist of a series of lines. No line will be more than 80 characters long, but may contain any number of words. Words consist of up to 20 upper and/or lower case letters, and will not be broken across lines. Spaces may appear freely around words, and at least one space separates multiple words on the same line. Note that words that contain the same letters but of differing case are considered to be anagrams of each other, thus ‘tIeD’ and ‘EdiT’ are anagrams. The file will be terminated by a line consisting of a single ‘#’.

Output

Output will consist of a series of lines. Each line will consist of a single word that is a relative ananagram in the input dictionary. Words must be output in lexicographic (case-sensitive) order. There will always be at least one relative ananagram.

Sample Input

ladder came tape soon leader acme RIDE lone Dreis peat ScAlE orb eye
Rides dealer NotE derail LaCeS drIed noel dire Disk mace Rob dries

Sample Output

Disk
NotE
derail
drIed
eye
ladder
soon

题的意思是输入一段英文文章,以“#”结束,按字典序输出这篇文章仅仅出现过一次的单词,这个单词也不能通过字母又一次排列与文章中的单词相同。
这个题主要是使用map做,把这段文章按字典序存在vector里,然后记录每个单词出现的次数,这就需要我们第一次用map将单词出现的次数与文章连接。但这篇文章有大写字母,也有小写字母,于是我们就得把单词全转变为小写,再第二次用map将全小写单词与原始单词连接。最后把只出现过一次的单词输出。
通过这个题我对map有了更深的理解,同时也意识到自己不会用迭代器。。。

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<string>
#include<map>
#include<vector>
using namespace std;
typedef vector<string>::iterator it;//定义一个迭代器
vector<string>v;
map<string,int>msi;
map<string,string>mss;
int main()
{
    string s,t;
    while(cin>>s&&s!="#")
    {
        t=s;
        v.push_back(s);
        for(int i=0;i<t.length();i++)
        t[i]=tolower(t[i]);//将大写字母转变为小写字母
        sort(t.begin(),t.end());
        mss[s]=t;//将小写的单词与原来的单词配对
        msi[t]++;//将单词出现的个数与小写的单词配对
    }
    sort(v.begin(),v.end());
    for(it i=v.begin();i!=v.end();i++)
    if(msi[mss[*i]]==1)//输出只出现过一次的单词
    cout<<*i<<endl;
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
这段代码定义了一个函数db_root_dir,用于返回不同数据集的根目录路径。函数的参数database指定了数据集的名称,可以是cifar-10、cifar-20、stl-10、imagenet、imagenet_50、imagenet_100或imagenet_200。函数首先检查输入的数据集名称是否合法,如果不合法则会抛出NotImplementedError异常。 如果输入的数据集名称是合法的,则函数会返回该数据集的根目录路径。例如,如果输入的数据集名称是cifar-10,则函数返回字符串'/path/to/cifar-10/',表示cifar-10数据集的根目录路径为/path/to/cifar-10/。实际上,这个路径是不正确的,只是为了示例而写的。 如果你想使用自己的数据集,可以修改这个函数,将相应的数据集名称和根目录路径进行映射。例如,如果你想使用D:\wjd作为自己的数据集根目录路径,可以按照以下方式修改函数: ```python def db_root_dir(database='wjd'): db_names = {'cifar-10', 'stl-10', 'cifar-20', 'imagenet', 'imagenet_50', 'imagenet_100', 'imagenet_200'} assert(database in db_names) if database == 'cifar-10': return 'D:/wjd/cifar-10/' elif database == 'cifar-20': return 'D:/wjd/cifar-20/' elif database == 'stl-10': return 'D:/wjd/stl-10/' elif database in ['imagenet', 'imagenet_50', 'imagenet_100', 'imagenet_200']: return 'D:/wjd/imagenet/' else: raise NotImplementedError ``` 这样,当你调用db_root_dir函数并传入相应的数据集名称时,函数将会返回对应的数据集根目录路径。例如,db_root_dir('cifar-10')将返回字符串'D:/wjd/cifar-10/',表示cifar-10数据集的根目录路径为D:/wjd/cifar-10/。你可以根据自己的需要,修改函数中的数据集名称和根目录路径,并将其保存到相关文件中,以便程序可以读取和使用你自己的数据集。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值