STL-D

Most crossword puzzle fans are used to anagrams — groups of words with the same letters in different orders — for example OPTS, SPOT, STOP,POTS and POST. Some words however do not have this attribute, no matter how you rearrange their letters, you cannot form another word.Such words are called ananagrams, an example is QUIZ. Obviously such definitions depend on the domain within which we are working; you might think that ATHENE is an ananagram, whereas any chemist would quickly produce ETHANE. One possible domain would be the entire English language, but this could lead to some problems. One could restrict the domain to, say, Music, in which case SCALE becomes a relative ananagram (LACES is not in the same domain) but NOTE is not since it can produce TONE. Write a program that will read in the dictionary of a restricted domain and determine the relative ananagrams. Note that single letter words are, ipso facto, relative ananagrams since they cannot be “rearranged” at all. The dictionary will contain no more than 1000 words.

Input

Input will consist of a series of lines. No line will be more than 80 characters long, but may contain any number of words. Words consist of up to 20 upper and/or lower case letters, and will not be broken across lines. Spaces may appear freely around words, and at least one space separates multiple words on the same line. Note that words that contain the same letters but of differing case are considered to be anagrams of each other, thus ‘tIeD’ and ‘EdiT’ are anagrams. The file will be terminated by a line consisting of a single ‘#’.

Output

Output will consist of a series of lines. Each line will consist of a single word that is a relative ananagram in the input dictionary. Words must be output in lexicographic (case-sensitive) order. There will always be at least one relative ananagram.

Sample Input

ladder came tape soon leader acme RIDE lone Dreis peat ScAlE orb eye
Rides dealer NotE derail LaCeS drIed noel dire Disk mace Rob dries

Sample Output

Disk
NotE
derail
drIed
eye
ladder
soon

题的意思是输入一段英文文章,以“#”结束,按字典序输出这篇文章仅仅出现过一次的单词,这个单词也不能通过字母又一次排列与文章中的单词相同。
这个题主要是使用map做,把这段文章按字典序存在vector里,然后记录每个单词出现的次数,这就需要我们第一次用map将单词出现的次数与文章连接。但这篇文章有大写字母,也有小写字母,于是我们就得把单词全转变为小写,再第二次用map将全小写单词与原始单词连接。最后把只出现过一次的单词输出。
通过这个题我对map有了更深的理解,同时也意识到自己不会用迭代器。。。

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<string>
#include<map>
#include<vector>
using namespace std;
typedef vector<string>::iterator it;//定义一个迭代器
vector<string>v;
map<string,int>msi;
map<string,string>mss;
int main()
{
    string s,t;
    while(cin>>s&&s!="#")
    {
        t=s;
        v.push_back(s);
        for(int i=0;i<t.length();i++)
        t[i]=tolower(t[i]);//将大写字母转变为小写字母
        sort(t.begin(),t.end());
        mss[s]=t;//将小写的单词与原来的单词配对
        msi[t]++;//将单词出现的个数与小写的单词配对
    }
    sort(v.begin(),v.end());
    for(it i=v.begin();i!=v.end();i++)
    if(msi[mss[*i]]==1)//输出只出现过一次的单词
    cout<<*i<<endl;
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值