STL-Q

Our chemical biologists have invented a new very useful form of life called stripies (in fact, they were first called in Russian polosatiki, but the scientists had to invent an English name to apply for an international patent). The stripies are transparent amorphous amebiform creatures that live in flat colonies in a jelly-like nutrient medium. Most of the time the stripies are moving. When two of them collide a new stripie appears instead of them. Long observations made by our scientists enabled them to establish that the weight of the new stripie isn’t equal to the sum of weights of two disappeared stripies that collided; nevertheless, they soon learned that when two stripies of weights m1 and m2 collide the weight of resulting stripie equals to 2sqrt(m1m2). Our chemical biologists are very anxious to know to what limits can decrease the total weight of a given colony of stripies. You are to write a program that will help them to answer this question. You may assume that 3 or more stipies never collide together.

Input

The first line of the input contains one integer N (1 <= N <= 100) - the number of stripies in a colony. Each of next N lines contains one integer ranging from 1 to 10000 - the weight of the corresponding stripie.

Output

The output must contain one line with the minimal possible total weight of colony with the accuracy of three decimal digits after the point.

Sample Input

3
72
30
50

Sample Output

120.000

这个Q题正好和昨天的B题相反:B题思路想起来简单,敲起来难;而Q题思路想起来难,敲起来简单。这道题的意思是有一种生物,当其中的两只发生碰撞时,他们的质量符合2×sqrt(m1×m2)。现在有n条这种生物,他们发生碰撞,求碰撞完后他们的最小总质量。我们设有3只这种生物,质量分别为a,b,c,最后的总质量为m。让他们相撞,则m=2×sqrt(a×(2×sqrt(b×c)),化简后得:m²=8×sqrt(a²×b×c),可知a越小,m越小。于是先让质量最大的两个相碰,以此类推,便得最小的质量!想到用贪心,这个问题就迎刃而解了。

#include<iostream>
#include<cstdio>
#include<queue>
#include<cmath>
using namespace std;
int main()
{
    int n;
    double num;
    cin>>n;
    priority_queue<double>q;
    for(int i=0;i<n;i++)
    {
        cin>>num;
        q.push(num);
    }
    double ans=q.top();
    while(q.size()>1)
    {
        double a=q.top();
        q.pop();
        double b=q.top();
        q.pop();
        ans=2*sqrt(a*b);
        q.push(ans);
    }
    printf("%.3f",ans);
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值