PAT 甲级 1029  Median

1029 Median (25 point(s))

Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1 = { 11, 12, 13, 14 } is 12, and the median of S2 = { 9, 10, 15, 16, 17 } is 15. The median of two sequences is defined to be the median of the nondecreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.

Given two increasing sequences of integers, you are asked to find their median.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N (≤2×10​5​​) is the size of that sequence. Then N integers follow, separated by a space. It is guaranteed that all the integers are in the range of long int.

Output Specification:

For each test case you should output the median of the two given sequences in a line.

Sample Input:

4 11 12 13 14
5 9 10 15 16 17

Sample Output:

13

Experiential Summing-up

This is a disgusting question. Because the memory limit is 1.5MB.  If you apply two int array with 2*10^5 size. You will exceed this limit. The code origin from Algorithm(《算法笔记》) is also fail to pass the last test point. So we can use a array to store the first line data. And compute as inputing the second line data.

(The purpose of using English to portray my solution is that to exercise the ability of my expression of English and accommodate PAT advanced level's style.We can make progress together by reading and comprehending it. Please forgive my basic grammar's and word's error. Of course, I would appreciated it if you can point out my grammar's and word's error in comment section.( •̀∀•́ ) Furthermore, Big Lao please don't laugh at me because I just a English beginner settle for CET6    _(:з」∠)_  )

Accepted Code

#include <cstdio>
#include <cstring>
const int maxn=200010;
int a[maxn];
int main()
{
	int n,m,t;
	scanf("%d",&n);
	for(int i=0;i<n;++i)
		scanf("%d",&a[i]);
	scanf("%d",&m);
	int j=0,count=0,median=(m+n-1)/2;
	for(int i=0;i<m;++i)
	{
		scanf("%d",&t);
		while(a[j]<t&&j<n)
		{
			if(count==median)
			{
				printf("%d\n",a[j]);
			}
			++j;
			++count;
		}
		if(count==median)
		{
			printf("%d\n",t);
		}
		++count;
	}
	while(j<n)
	{
		if(count==median)
		{
			printf("%d\n",a[j]);
			break;
		}
		++count;
		++j;
	}
	return 0;
}

 

评论 5
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值