6120 Problem D String Subtraction (20)

问题 D: String Subtraction (20)

时间限制: 1 Sec  内存限制: 32 MB

题目描述

Given two strings S1 and S2, S = S1 - S2 is defined to be the remaining string after taking all the characters in S2 from S1. Your task is simply to calculate S1 - S2for any given strings. However, it might not be that simple to do it fast.

输入

Each input file contains one test case. Each case consists of two lines which gives S1 and S2, respectively. The string lengths of both strings are no more than 104. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.

输出

For each test case, print S1 - S2 in one line.

样例输入

They are students.
aeiou

样例输出

Thy r stdnts.

经验总结

题意是给出两个字符串,输出将第二个字符串中出现的字符去除的第一个字符串,难度不大~~

AC代码

#include <cstdio>
#include <cstring>
int main()
{
	char s1[10010],s2[10010];
	int flag[255];
	while(gets(s1))
	{
		memset(flag,0,sizeof(flag));
		gets(s2);
		for(int i=0;s2[i]!='\0';++i)
			flag[s2[i]]=true;
		for(int i=0;s1[i]!='\0';++i)
			if(flag[s1[i]]==false)
				printf("%c",s1[i]);
	}
	return 0;
} 

 

  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值