问题 D: String Subtraction (20)

问题 D: String Subtraction (20)
[命题人 : 外部导入]
时间限制 : 1.000 sec 内存限制 : 32 MB

题目描述
Given two strings S1 and S2, S = S1 - S2 is defined to be the remaining string after taking all the characters in S2 from S1. Your task is simply to calculate S1 - S2for any given strings. However, it might not be that simple to do it fast.
输入
Each input file contains one test case. Each case consists of two lines which gives S1 and S2, respectively. The string lengths of both strings are no more than 104. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.
输出
For each test case, print S1 - S2 in one line.
样例输入 Copy
They are students.
aeiou
样例输出 Copy
Thy r stdnts.

#include<stdio.h>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<fstream>
using namespace std;
char a[10010];
char b[10010];
char ans[10010];
int main() {//输出超限一般是输出有问题,或者是内部。比如越界了,  
//一点.-去‘a/A'不一定就找得到下标是正的!!!
//	freopen("d://in.txt","r",stdin);

	while(	cin.getline(a,10010)) {
		cin.getline(b,10010);
		int lena = strlen(a);
		int lenb = strlen(b);
		//如果两个for暴力搜索很慢,用hash
		bool test[600] = {false};


		for(int i=0; i<lenb; i++) {
			test[b[i]] = true;
			//小心输出超限  A 然后才是a 如果-a容易负数
			//事实证明不要乱搞 
		}
		int num = 0;
		for(int i = 0; i < lena; i++) {
			if(test[a[i]]==false) {
				printf("%c",a[i]);
			}

		}
		printf("\n");
	}

//	ans[num] = '\0';
//	for(int i=0;i<num;i++){
//		printf("%c",ans[i]);
//	}


	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值