【排序专题】实践2-众数

众数

Description

众数是指在一组数据中,出现次数最多的数。例如:1, 1, 3 中出现次数最多的数为 1,则众数为 1。

给定一组数,你能求出众数吗?

Input

输入数据有2行

第一行输入N(1~3万)

第2行n个数表示排序的数(可重复)(小于100)

Output

最大的

Sample Input 1 

 
       

12

1 2 3 4 5 5 6 7 8 9 10 11 12

Sample Output 1

5 2
      我的思路

N大数小使用木桶排序查看次数

   


      我的代码

   

  Lauguage

  C++

    Code

 

#include <bits/stdc++.h>
using namespace std;
int a[101];
int main()
{
    int n;
    cin>>n;
    int i;
    for(i=1;i<=n;i++){
    	int x;
    	cin>>x;
    	a[x]++;
	}
	int max=0;
	for(i=0;i<=100;i++)if(a[i]>max)max=a[i];
	for(i=0;i<=100;i++)if(a[i]==max)cout<<i<<" "<<max<<endl;
    
}


   



BYE~


转载于:https://www.cnblogs.com/smallfang/p/9278038.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值