POJ 3274 Gold Balanced Lineup

Gold Balanced Lineup

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 17013 Accepted: 4803

Description

Farmer John's N cows (1 ≤ N ≤ 100,000) share many similarities. In fact, FJ has been able to narrow down the list of features shared by his cows to a list of only K different features (1 ≤ K ≤ 30). For example, cows exhibiting feature #1 might have spots, cows exhibiting feature #2 might prefer C to Pascal, and so on.

FJ has even devised a concise way to describe each cow in terms of its "feature ID", a single K-bit integer whose binary representation tells us the set of features exhibited by the cow. As an example, suppose a cow has feature ID = 13. Since 13 written in binary is 1101, this means our cow exhibits features 1, 3, and 4 (reading right to left), but not feature 2. More generally, we find a 1 in the 2^(i-1) place if a cow exhibits feature i.

Always the sensitive fellow, FJ lined up cows 1..N in a long row and noticed that certain ranges of cows are somewhat "balanced" in terms of the features the exhibit. A contiguous range of cows i..j is balanced if each of the K possible features is exhibited by the same number of cows in the range. FJ is curious as to the size of the largest balanced range of cows. See if you can determine it.

Input

Line 1: Two space-separated integers, N and K.
Lines 2..N+1: Line i+1 contains a single K-bit integer specifying the features present in cow i. The least-significant bit of this integer is 1 if the cow exhibits feature #1, and the most-significant bit is 1 if the cow exhibits feature #K.

Output

Line 1: A single integer giving the size of the largest contiguous balanced group of cows.

Sample Input

7 3
7
6
7
2
1
4
2

Sample Output

4

Hint

In the range from cow #3 to cow #6 (of size 4), each feature appears in exactly 2 cows in this range

Source

USACO 2007 March Gold

官方解题报告——

Consider the partial sum sequence of each of the k features built by taking the

sum of all the values up to position i. The problem is equivalent to:

Given an array s[n][k], find i,j, with the biggest separation for which s[ i ]

[l]-s[j][l] is constant for all l.

The problem is now to do this efficiently. Notice that s[ i ][l]-s[j][l] being

constant for all l is equivalent to s[ i ][l]-s[j][l]=s[ i ][1]-s[j][1] for all

l, which can be rearranged to become s[ i ][l]-s[ i ][1]=s[j][l]-s[j][1] for all

l. Therefore, we can construct another array a[n][k] where a[ i ][j]=s[ i ][j]-

s[ i ][1] and the goal is to find i and j with the biggest separation for which

a[ i ][l]=a[j][l] for all l.

This can be done by sorting all the a[ i ] entries, which takes O(nklogn) time

(although in practice rarely will all k elements be compared). Another

alternative is to go by hashing, giving an O(nk) solution. Both solutions are

fairly straightforward once the final array is constructed.

意思就是对每天的增长进行累加 最后对累加的数组减去数组第一个特征的累加值 

例子 

2  3

7

2

转换到最后后  当i ,j 两行各位数都相同时  求max(i-j)即为答案

ac代码

#include <iostream>
#include <stdio.h>
#include <vector>
#include <algorithm>
#include <map>
#include <stdlib.h>
#include <string.h>
#include <sstream>
#include <math.h>
using namespace std;
const int mod=100007;
int b[100005][35],a[35],end,n,k;
int flag[100005];
vector<int>v[100010];
int same(int x,int y){
	for(int i=2;i<=k;i++){
		if(b[x][i]!=b[y][i])return 0;
	}
	return 1;
}
int suan(int x,int y){
	if(x>y)return x-y;
	else return y-x;
}
int sun(int x){
	int zz=b[x][1];
	for(int j=2;j<=k;j++){
		if(b[x][j]!=zz)return 0;
	}
	return 1;
}
int main()
{
	    a[1]=1;
	    for(int i=2;i<=31;i++){
	    	a[i]=a[i-1]*2;
    	}
	    scanf("%d%d",&n,&k);
	    memset(b,0,sizeof(b));
	    int s,en,key=0;
	    end=0;
	    for(int i=1;i<=n;i++){
	     	scanf("%d",&s);
	     	for(int j=2;j<=k+1;j++){
	     		if(s%a[j]){
	     			s-=s%a[j];
	     			b[i][j-1]++;
				 }	
     			if(i!=1)b[i][j-1]+=b[i-1][j-1];
			 }
			 if(sun(i))end=max(i,end);
		}
		for(int i=1;i<=n;i++){
			key=0;
		    en=b[i][1];
		    b[i][1]=0;
	        for(int j=2;j<=k;j++){
			    b[i][j]-=en;
			    key+=b[i][j];
		}
		   key=abs(key);
		   key%=mod;
		   flag[i]=key;
		   v[key].push_back(i);
	  }
	  for(int i=1;i<=n;i++){
	  	int n1=v[flag[i]].size();
	  	for(int j=0;j<n1;j++){
	  		if(same(i,v[flag[i]][j])){
	  			end=max(v[flag[i]][j]-i,end);
			  }
		  }
	  }
	  printf("%d\n",end);	
}

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值