HDU 5461.Largest Point【2015 ACM/ICPC Asia Regional Shenyang Online】【排序】9月19

Largest Point

Problem Description
Given the sequence  A  with  n  integers  t1,t2,,tn . Given the integral coefficients  a  and  b . The fact that select two elements  ti  and  tj  of  A  and  ij  to maximize the value of  at2i+btj , becomes the largest point.
 

Input
An positive integer  T , indicating there are  T  test cases.
For each test case, the first line contains three integers corresponding to  n (2n5×106), a (0|a|106)  and  b (0|b|106) . The second line contains  n integers  t1,t2,,tn  where  0|ti|106  for  1in .

The sum of  n  for all cases would not be larger than  5×106 .
 

Output
The output contains exactly  T  lines.
For each test case, you should output the maximum value of  at2i+btj .
 

Sample Input
  
  
2 3 2 1 1 2 3 5 -1 0 -3 -3 0 3 3
 

Sample Output
  
  
Case #1: 20 Case #2: 0
 
哎呀妈呀,晕死了:
#include<cstdio>
#include<algorithm>
#include<iostream>
using namespace std;
#define maxn 5000005
typedef long long  LL;
struct num{
    LL n,id;
};
bool cmp1(num x,num y){
    if(x.n<y.n) return true;
    else return false;
}
bool cmp2(num x,num y){
    if(x.n>y.n) return true;
    else return false;
}
int T,n,a,b,cnt;
LL x;
num ma[5],mb[5];
int main(){
    scanf("%d",&T);
    for(int p=1;p<=T;p++){
        scanf("%d%d%d",&n,&a,&b);
        for(int i=0;i<n;i++){
            scanf("%lld",&x);
            if(i<3){
                ma[i].n=x*x;
                ma[i].id=i+1;
                mb[i].n=x;
                mb[i].id=i+1;
            }
            else{
                ma[3].n=x*x;
                ma[3].id=i+1;
                mb[3].n=x;
                mb[3].id=i+1;
                if(a<0) sort(ma,ma+4,cmp1);
                else sort(ma,ma+4,cmp2);
                if(b<0) sort(mb,mb+4,cmp1);
                else sort(mb,mb+4,cmp2);
            }
        }
        LL ans=100000000;
        ans=ans*ans;
        ans= -ans;
        int xxxx=n<4?n:3;
        for(int i=0;i<xxxx;i++)
        for(int j=0;j<xxxx;j++)
        if(ma[i].id!=mb[j].id)
            ans=max(ans,ma[i].n*(LL)a+mb[j].n*(LL)b);
        printf("Case #%d: %lld\n",p,ans);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值