HDU 5461Largest Point

21 篇文章 0 订阅
17 篇文章 0 订阅

Largest Point

Time Limit: 1500/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 527    Accepted Submission(s): 228


Problem Description
Given the sequence  A  with  n  integers  t1,t2,,tn . Given the integral coefficients  a  and  b . The fact that select two elements  ti  and  tj  of  A  and  ij  to maximize the value of  at2i+btj , becomes the largest point.
 

Input
An positive integer  T , indicating there are  T  test cases.
For each test case, the first line contains three integers corresponding to  n (2n5×106), a (0|a|106)  and  b (0|b|106) . The second line contains  n  integers  t1,t2,,tn  where  0|ti|106  for  1in .

The sum of  n  for all cases would not be larger than  5×106 .
 

Output
The output contains exactly  T  lines.
For each test case, you should output the maximum value of  at2i+btj .
 

Sample Input
  
  
2 3 2 1 1 2 3 5 -1 0 -3 -3 0 3 3
 

Sample Output
  
  
Case #1: 20 Case #2: 0


简单题  求a*ti*ti+b*tj(i!=j)的最大值



#include <iostream>
#include <cstdio>
#include <cstring>
#include <stack>
#include <queue>
#include <map>
#include <set>
#include <vector>
#include <cmath>
#include <algorithm>
using namespace std;

int tz[5000050],tf[5000050];
bool compare(int a,int b)
{
    return a<b;
}
int main()
{
    int T,tt=1;
    scanf("%d",&T);
    while(T--)
    {
        int n;
        long long a,b;
        int tzlen=0,tflen=0;
        scanf("%d%lld%lld",&n,&a,&b);
        for(int i=0; i<n; i++)
        {
            int num;
            scanf("%d",&num);
            if(num>=0)
                tz[tzlen++]=num;
            else tf[tflen++]=-num;
        }
        sort(tz,tz+tzlen,compare);
        sort(tf,tf+tflen,compare);
        long long Max;
        if(tzlen>1&&tflen>1)
        {
            if(a>=0&&b>=0)
            {
                Max=a*tz[tzlen-1]*tz[tzlen-1]+b*tz[tzlen-2];
                Max=max(Max,a*tz[tzlen-2]*tz[tzlen-2]+b*tz[tzlen-1]);
                Max=max(Max,a*tf[tflen-1]*tf[tflen-1]+b*tz[tzlen-1]);
            }
            else if(a>=0&&b<0)
            {
                Max=-b*tf[tflen-1]+a*tz[tzlen-1]*tz[tzlen-1];
                Max=max(Max,-b*tf[tflen-1]+a*tf[tflen-2]*tf[tflen-2]);
                Max=max(Max,-b*tf[tflen-2]+a*tf[tflen-1]*tf[tflen-1]);
            }
            else if(a<0&&b>=0)
            {
                Max=a*tz[0]*tz[0]+b*tz[tzlen-1];
                Max=max(Max,a*tf[0]*tf[0]+b*tz[tzlen-1]);
            }
            else
            {
                Max=-b*tf[tflen-1]+a*tz[0]*tz[0];
                Max=max(Max,-b*tf[tflen-1]+a*tf[0]*tf[0]);
            }
        }else if(tzlen==0)
        {
            if(a>=0&&b>=0)
            {
                Max=a*tf[tflen-1]*tf[tflen-1]-b*tf[0];
            }
            else if(a>=0&&b<0)
            {
                Max=-b*tf[tflen-1]+a*tf[tflen-2]*tf[tflen-2];
                Max=max(Max,-b*tf[tflen-2]+a*tf[tflen-1]*tf[tflen-1]);
            }
            else if(a<0&&b>=0)
            {
                Max=a*tf[1]*tf[1]-b*tf[0];
                Max=max(Max,a*tf[0]*tf[0]-b*tf[1]);
            }
            else
            {
                Max=-b*tf[tflen-1]+a*tf[0]*tf[0];
            }

        }else if(tflen==0)
        {
            if(a>=0&&b>=0)
            {
                Max=a*tz[tzlen-1]*tz[tzlen-1]-b*tz[tzlen-2];
                Max=max(Max,a*tz[tzlen-2]*tz[tzlen-2]-b*tz[tzlen-1]);
            }
            else if(a>=0&&b<0)
            {
                Max=a*tz[tzlen-1]*tz[tzlen-1]-b*tz[0];
            }
            else if(a<0&&b>=0)
            {
                Max=a*tz[0]*tz[0]-b*tz[tzlen-1];
            }
            else
            {
                Max=a*tz[0]*tz[0]-b*tz[1];
                Max=max(Max,a*tz[1]*tz[1]-b*tz[0]);
            }

        }else
        {
            Max=a*tz[0]*tz[0]-b*tf[0];
            Max=max(Max,a*tf[0]*tf[0]+b*tz[0]);
        }

        printf("Case #%d: %lld\n",tt++,Max);
    }
}


评论 4
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值