HDU 1068.Girls and Boys【二分图匹配(最大独立集)】【5月6日】

Girls and Boys

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9926    Accepted Submission(s): 4554


Problem Description
the second year of the university somebody started a study on the romantic relations between the students. The relation “romantically involved” is defined between one girl and one boy. For the study reasons it is necessary to find out the maximum set satisfying the condition: there are no two students in the set who have been “romantically involved”. The result of the program is the number of students in such a set.

The input contains several data sets in text format. Each data set represents one set of subjects of the study, with the following description:

the number of students
the description of each student, in the following format
student_identifier:(number_of_romantic_relations) student_identifier1 student_identifier2 student_identifier3 ...
or
student_identifier:(0)

The student_identifier is an integer number between 0 and n-1, for n subjects.
For each given data set, the program should write to standard output a line containing the result.
 

Sample Input
  
  
7 0: (3) 4 5 6 1: (2) 4 6 2: (0) 3: (0) 4: (2) 0 1 5: (1) 0 6: (2) 0 1 3 0: (2) 1 2 1: (1) 0 2: (1) 0
 

Sample Output
  
  
5 2
 

要求最大独立集。最大独立集 = 节点数 - 最大匹配:

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int MAX = 1005;
int Map[MAX][MAX], vis[MAX], link[MAX];
int n, a, m, b, sum;
bool PP(int node)
{
    for(int i = 0;i < n; ++i)
    {
        if(!vis[i] && Map[node][i])
        {
            vis[i] = 1;
            if(link[i] == -1 || PP(link[i]))
            {
                link[i] = node;
                return true;
            }
        }
    }
    return false;
}
int main()
{
    while(scanf("%d", &n) != EOF)
    {
        sum = 0;
        memset(Map, 0, sizeof(Map));
        for(int i = 0;i < n; ++i) link[i] = -1;
        for(int i = 0;i < n; ++i)
        {
            scanf("%d: (%d)", &a, &m);
            while(m--)
            {
                scanf("%d", &b);
                Map[a][b] = 1;
            }
        }
        for(int i = 0;i < n; ++i)
        {
            memset(vis, 0, sizeof(vis));
            if(PP(i)) sum ++;
        }
        cout << n-sum/2 << endl;
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值