POJ 2387 Til the Cows Come Home

                                          Til the Cows Come Home

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 72804 Accepted: 24337

Description

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible. 

Farmer John's field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it. 

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.

Input

* Line 1: Two integers: T and N 

* Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.

Output

* Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.

Sample Input

5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100

Sample Output

90

Hint

INPUT DETAILS: 

There are five landmarks. 

OUTPUT DETAILS: 

Bessie can get home by following trails 4, 3, 2, and 1.

 

题意:  给你n个点之间的关系,让你求第n个点到第1个点的最短距离

思路:没啥好说的直接,这三种方法都可以的啦!!!!!

  1. Floyed-Warshall(弗洛伊德)
  2. Dijkstra(迪杰斯特拉)
  3. SPFA

下面附上大佬对这三种个方法的详细解释:  https://blog.csdn.net/ggn_2015/article/details/75502100

 

 

 

AC代码:

#include <stdio.h>
#include <iostream>
#include <string.h>
#include <vector>
#include <string>
#include <algorithm>
#include <queue>
#include <stack>
#include <map>
#include <set>
using namespace std;
typedef long long ll;
const int MAXN = 1000 + 10;
const int INF = 0x3f3f3f3f;
int t, n, mp[MAXN][MAXN];

void init(int n)
{
    for(int i = 0; i < n; i++)
    {
        for(int j = 0; j < n; j++)
        {
            if(i == j)     mp[i][j] = 0;//本算法适用于无环图,自环设置成0
            else mp[i][j] = mp[j][i] = INF;//初始化mp(求的是最短路所以需要初始化为INF)
        }
    }
}

void getmap(int t)
{
    int u, v, val;
    while(t--)
    {
        scanf("%d %d %d", &u, &v, &val);
        u--, v--;//使图的起始点从(0,0)开始
        mp[u][v] = mp[v][u] = min(mp[u][v], val);//无向图 mp[i][j] = mp[j][i] 为什么要去最小值?
        //mp[u][v] = min(mp[u][v], val)  //有向图
    }
}

bool vis[MAXN]; int dis[MAXN];//vis用来标记是否用过该点;dis 用来记录最短路径长度

void djk(int st, int ed)//st 是起始点的编号 ed 要求的点的编号
{
    //初始化vis,dis数组
    for(int i = 0; i < n; i++)
    {
        vis[i] = false ;
        dis[i] = mp[st][i];//dis[i]表示第 i 个点到起始点(0, 0)的最短距离
    }
    vis[st] = true;
    for(int i = 1; i < n; i++)//遍历其他n - 1 个点
    {
        int mn = INF, id = -1;
        for(int j = 0; j < n; j++)
        {
            if(!vis[j] && dis[j] < mn)
            {
                mn = dis[j];
                id = j;
            }
        }
        if(id == -1)    break;//判断是否全部遍历,是则退出
        vis[id] = true;//标记为已经遍历
        for(int j = 0; j < n; j++)
        {
            if(!vis[j] && mp[id][j] != INF)//
            {
                dis[j] = min(dis[j], dis[id] + mp[id][j]);//DP 做法
//                if(dis[j] > dis[id] + mp[id][j])//常规做法
//                    dis[j] = dis[id] + mp[id][j];
            }
        }
    }
    printf("%d\n", (dis[ed] == INF) ? -1 : dis[ed]);
}

int main()
{
    int t;
    while(scanf("%d %d", &t, &n) != EOF)
    {
        init(n);//初始化
        getmap(t);//建图
        djk(0, n - 1);
    }
    return 0;
}

 

 

 

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值