Language:Default
Til the Cows Come Home
Description
Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible.
Farmer John's field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it. Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists. Input
* Line 1: Two integers: T and N
* Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100. Output
* Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.
Sample Input 5 5 1 2 20 2 3 30 3 4 20 4 5 20 1 5 100 Sample Output 90 Hint
INPUT DETAILS:
There are five landmarks. OUTPUT DETAILS: Bessie can get home by following trails 4, 3, 2, and 1. |
题目大意:N个坐标点,T组数据,确定贝西必须走回谷仓的最小距离。并且保证有这样的路线存在。
解题思路:求N点到1的单源最短路。
#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
int vis[2005];
int dis[2005];
const int INF=0x3f3f3f3f;
int map[2005][2005];
int T,N;
int Dijkstra(int x){
memset(vis,0,sizeof(vis));
for (int l=0; l<=2004; l++) {
dis[l]=INF;
}
//memset(dis,INF, sizeof(dis));
dis[x]=0;
for (int i=1; i<=N; i++) {
int u=-1,min=INF;
for (int j=1; j<=N; j++) {
if (!vis[j]&&dis[j]<min) {
u=j;
min=dis[j];
}
}
//if (u==-1) return -1;
vis[u]=1;
for (int k=1; k<=N; k++) {
if (!vis[k]&&map[u][k]+dis[u]<dis[k]) {
dis[k]=map[u][k]+dis[u];
}
}
}
return dis[1];
}
int main(){
int a,b,c;
while (scanf("%d%d",&T,&N)!=EOF) {
for (int i=1; i<=N; i++) {
for (int j=1; j<=N; j++) {
map[i][j]=map[j][i]=INF;
}
}
for (int i=1; i<=T; i++) {
cin>>a>>b>>c;
if (map[a][b]>c) {
map[a][b]=map[b][a]=c;
}
}
printf("%d\n",Dijkstra(N));
}
return 0;
}