Code Formatter

133 篇文章 17 订阅
Code Formatter
Time Limit: 1 Second      Memory Limit: 32768 KB

Some companies have special requirements for source code format, and it is also good for programmers to keep consistent code style. You are asked to write a simple code formatter for the company to help the poor programmers.

The first thing you need to do is to check whether the source code contains tabs (represented as the escape character '/t'), since different terminals have different ways to display tabs, it's better not to use them, but replace them with spaces. The code formatter should replace each tab of the source code with 4(four) blank spaces.

Then you need to remove trailing spaces of the source file. Trailing spaces are one or more consecutive whitespaces right before the EOL (end of line, represented as the escape character '/n'), and they usually have no meaning in most programming language, so they can be safely removed.

Input

The input contains multiple test cases!

The first line is an integer N indicating the number of test cases. Each test case is the source which contains not more than 100 lines given to you to format. A single line containing only "##" marks the end of a test case.

Output

For each test case, output a log of the formatter in two lines of the following format:

#A tab(s) replaced #B trailing space(s) removed Where #A is the number of tabs replaced and #B is the number of trailing spaces removed.

Sample Input

2
include <stdio.h>

int main()
{
	int a,b;
	while(scanf("%d %d",&a, &b) != EOF) 
		printf("%d/n",a+b);             
        
}
##

##

Sample Output

4 tab(s) replaced
22 trailing space(s) removed
0 tab(s) replaced
0 trailing space(s) removed

Note

In order to show the whitespaces precisely, all the characters in sample input are underlined. They are not the underscore character

 

 

这是07年浙江省赛的一道题,一看AC率吓一跳,看题目并不难,那就是输入输出和其他的问题了……

 

关键点:

有可能出现这种情况:

先空格后Tab为一行,也就是说tab必须转换成空格,而不是单单数数的问题了;

在此贴上我的代码:

 

/*
2164027 2010-04-15 20:17:29 Accepted  2851 C++ 0 184 zhangruiqing 
*/
#include<iostream>
#include<string>
using namespace std;

char str[110];

int main()
{
	int end=0,tab=0,blank=0,tb=0,cases;
	scanf("%d",&cases);
	getchar();
	while(cases--)
	{
		while(gets(str))
		{
			tb=0;
			if(strcmp(str,"##")!=0)
			{
				for(int i=0;i<=strlen(str);i++)
				{
					if(str[i]=='\t')
					{
						tab++;
						tb+=4;
					}
					else if (str[i]==' ')
					{
						tb++;
					}
					else if(str[i]=='\0')
					{
						blank+=tb;
						tb=0;
					}
					else tb=0;
				}
			}
			else
			{
				printf("%d tab(s) replaced\n%d trailing space(s) removed\n",tab,blank);
				end=tab=blank=tb=0;
			}
		}
	}
	return 0;
}



评论 4
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值