HDU 1385 Minimum Transport Cost

Minimum Transport Cost

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8984    Accepted Submission(s): 2366


Problem Description
These are N cities in Spring country. Between each pair of cities there may be one transportation track or none. Now there is some cargo that should be delivered from one city to another. The transportation fee consists of two parts: 
The cost of the transportation on the path between these cities, and

a certain tax which will be charged whenever any cargo passing through one city, except for the source and the destination cities.

You must write a program to find the route which has the minimum cost.
 

Input
First is N, number of cities. N = 0 indicates the end of input.

The data of path cost, city tax, source and destination cities are given in the input, which is of the form:

a11 a12 ... a1N
a21 a22 ... a2N
...............
aN1 aN2 ... aNN
b1 b2 ... bN

c d
e f
...
g h

where aij is the transport cost from city i to city j, aij = -1 indicates there is no direct path between city i and city j. bi represents the tax of passing through city i. And the cargo is to be delivered from city c to city d, city e to city f, ..., and g = h = -1. You must output the sequence of cities passed by and the total cost which is of the form:
 

Output
From c to d :
Path: c-->c1-->......-->ck-->d
Total cost : ......
......

From e to f :
Path: e-->e1-->..........-->ek-->f
Total cost : ......

Note: if there are more minimal paths, output the lexically smallest one. Print a blank line after each test case.

 

Sample Input
  
  
5 0 3 22 -1 4 3 0 5 -1 -1 22 5 0 9 20 -1 -1 9 0 4 4 -1 20 4 0 5 17 8 3 1 1 3 3 5 2 4 -1 -1 0
 

Sample Output
  
  
From 1 to 3 : Path: 1-->5-->4-->3 Total cost : 21 From 3 to 5 : Path: 3-->4-->5 Total cost : 16 From 2 to 4 : Path: 2-->1-->5-->4 Total cost : 17
 

Source
 

Recommend
Eddy
 


题目要求求最短路 多条的时候取字典序最小的

看discuss这个题好像比较水 但是一直wa

建反向边更新可以ac

但是正向+判断就是wa

难道判断写错了?。。。

很奇怪啊


先贴上ac代码

逆向思维确实比较吊

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<algorithm>
#include<queue>
using namespace std;
struct self
{
    int x,y,w,nxt;
}s[111111];
int fst[1111];
int x,y,w;
int d[1111];
int m,n,newn;
int flag[1111];
int cost[1111];
int fa[1111];
queue<int>q;
void spfa()
{
    memset(flag,0,sizeof(flag));
    memset(d,0x3f,sizeof(d));
    d[y]=0;
    q.push(y);
    while(!q.empty())
    {
        int u=q.front();
        q.pop();
        flag[u]=0;
        for(int e=fst[u];e!=-1;e=s[e].nxt)
        {
            int v=s[e].y;
            if(d[v]==d[u]+s[e].w+cost[v])
                fa[v]=min(fa[v],u);
            if(d[v]>d[u]+s[e].w+cost[v])
            {
                d[v]=d[u]+s[e].w+cost[v];
                fa[v]=u;
                if(!flag[v])
                {
                    flag[v]=1;
                    q.push(v);
                }
            }
        }
    }
    printf("From %d to %d :\n",x,y);
    printf("Path: ");
    for(int e=x;e!=y;e=fa[e])
        printf("%d-->",e);
    printf("%d\n",y);
    if(x!=y)
        printf("Total cost : %d\n\n",d[x]-cost[x]);
    else
        printf("Total cost : %d\n\n",d[x]);
}
void add(int x,int y,int w)
{
    n++;
    s[n].x=x;
    s[n].y=y;
    s[n].w=w;
    s[n].nxt=fst[x];
    fst[x]=n;
}

int main()
{
    while(scanf("%d",&m)&&m)
    {
        memset(fst,-1,sizeof(fst));
        n=0;
        for(int i=1;i<=m;i++)
            for(int j=1;j<=m;j++)
            {
                scanf("%d",&w);
                if(w!=-1)
                    add(j,i,w);
            }
        for(int i=1;i<=m;i++)scanf("%d",&cost[i]);
        while(scanf("%d%d",&x,&y)==2)
        {
            if(x==-1 && y==-1)
                break;
            spfa();
        }
    }
}



然后正向+判断的代码

奇怪的地方在于

如果按中点大小顺序排序 是可以ac的

但是不排序就不能过

但是感觉不排序也没问题啊!

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<algorithm>
#include<queue>
using namespace std;
struct self
{
    int x,y,w,nxt;
}s[111111];
int fst[1111];
int x,y,w;
int d[1111];
int m,n;
int flag[1111];
int cost[1111];
int fa[1111];
int name[1111][1111];
int cmp(self a,self b)
{
    return a.x==b.x?a.y>b.y:a.x>b.x;
}
queue<int>q;
void dfs(int u)
{
    if(u==-1)return;
    dfs(fa[u]);
    printf("%d-->",u);
}
int lessa(int u,int v)
{
    name[u][name[u][0]+1]=v;
    int length=max(name[u][0]+1,name[v][0]);
    for(int i=1;i<=length;i++)
    {
        if(name[u][i]<name[v][i])return 1;
        if(name[u][i]>name[v][i])return 0;
    }
    if(name[u][0]+1<name[v][0])return 1;
    return 0;
}
void change(int v,int u)
{
    name[v][0]=name[u][0]+1;
    for(int i=1;i<=name[u][0];i++)
        name[v][i]=name[u][i];
    name[v][name[v][0]]=v;
}
void spfa()
{
    memset(flag,0,sizeof(flag));
    memset(d,0x3f,sizeof(d));
    d[x]=0;
    q.push(x);
    fa[x]=-1;
    name[x][0]=1;
    name[x][1]=x;
    while(!q.empty())
    {
        int u=q.front();
        q.pop();
        flag[u]=0;
        for(int e=fst[u];e!=-1;e=s[e].nxt)
        {
            int v=s[e].y;
            if(d[v]==d[u]+s[e].w+cost[v])
            {
                if(lessa(u,v))
                {
                    change(v,u);
                    fa[v]=u;
                }
            }
            if(d[v]>d[u]+s[e].w+cost[v])
            {
                d[v]=d[u]+s[e].w+cost[v];
                change(v,u);
                fa[v]=u;
                if(!flag[v])
                {
                    flag[v]=1;
                    q.push(v);
                }
            }
        }
    }
    printf("From %d to %d :\n",x,y);
    printf("Path: ");
    dfs(fa[y]);
    printf("%d\n",y);
    if(x!=y)
        printf("Total cost : %d\n\n",d[y]-cost[y]);
    else
        printf("Total cost : %d\n\n",d[y]);
}
void add(int x,int y,int w)
{
    n++;
    s[n].x=x;
    s[n].y=y;
    s[n].w=w;
    s[n].nxt=fst[x];
    fst[x]=n;
}

int main()
{
    while(scanf("%d",&m)&&m)
    {
        memset(fst,-1,sizeof(fst));
        n=0;
        for(int i=1;i<=m;i++)
            for(int j=1;j<=m;j++)
            {
                scanf("%d",&w);
                if(w!=-1)
                {
                    //add(i,j,w);
                    n++;
                    s[n].x=i;
                    s[n].y=j;
                    s[n].w=w;
                }
            }
        for(int i=1;i<=m;i++)scanf("%d",&cost[i]);
        sort(s+1,s+n+1,cmp);
        for(int i=1;i<=n;i++)
        {
            s[i].nxt=fst[s[i].x];
            fst[s[i].x]=i;
        }
        while(scanf("%d%d",&x,&y)==2)
        {
            if(x==-1 && y==-1)
                break;
            spfa();
        }
    }
}

简直醉了

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值