题目描述
You are given an integer sequence of length n, a1,…,an. Let us consider performing the following n operations on an empty sequence b.
The i-th operation is as follows:
1.Append ai to the end of b.
2.Reverse the order of the elements in b.
Find the sequence b obtained after these n operations.
Constraints
1≤n≤2×105
0≤ai≤109
n and ai are integers.
输入
Input is given from Standard Input in the following format:
n
a1 a2 … an
输出
Print n integers in a line with spaces in between. The i-th integer should be bi.
样例输入
4 1 2 3 4
样例输出
4 2 1 3 提示
After step 1 of the first operation, b becomes: 1.
After step 2 of the first operation, b becomes: 1.
After step 1 of the second operation, b becomes: 1,2.
After step 2 of the second operation, b becomes: 2,1.
After step 1 of the third operation, b becomes: 2,1,3.
After step 2 of the third operation, b becomes: 3,1,2.
After step 1 of the fourth operation, b becomes: 3,1,2,4.
After step 2 of the fourth operation, b becomes: 4,2,1,3.
Thus, the answer is 4 2 1 3.
规律:a[n] . a[n-2] . a[n-4] . ...a[n-5] . a[n-3] . a[n-1]
代码如下:
#include <bits/stdc++.h>
using namespace std;
#define ll long long
#define pre(i,x,n) for(int i=x;i<=n;i++)
int n,a[200010],b[200010];
int main()
{
int head=1,tail,temp=1;
scanf("%d",&n);
tail=n;
for(int i=1;i<=n;i++)
scanf("%d",&a[i]);
for(int i=n;i>0;i--)
{
if(temp)
{
b[head]=a[i];
head++;
temp=!temp;
}
else
{
b[tail]=a[i];
tail--;
temp=!temp;
}
}
printf("%d",b[1]);
for(int i=2;i<=n;i++)
printf(" %d",b[i]);
putchar('\n');
return 0;
}