1060. Are They Equal (25)

时间限制
50 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

If a machine can save only 3 significant digits, the float numbers 12300 and 12358.9 are considered equal since they are both saved as 0.123*105 with simple chopping. Now given the number of significant digits on a machine and two float numbers, you are supposed to tell if they are treated equal in that machine.

Input Specification:

Each input file contains one test case which gives three numbers N, A and B, where N (<100) is the number of significant digits, and A and B are the two float numbers to be compared. Each float number is non-negative, no greater than 10100, and that its total digit number is less than 100.

Output Specification:

For each test case, print in a line “YES” if the two numbers are treated equal, and then the number in the standard form “0.d1…dN*10^k” (d1>0 unless the number is 0); or “NO” if they are not treated equal, and then the two numbers in their standard form. All the terms must be separated by a space, with no extra space at the end of a line.

Note: Simple chopping is assumed without rounding.
Sample Input 1:

3 12300 12358.9

Sample Output 1:

YES 0.123*10^5

Sample Input 2:

3 120 128

Sample Output 2:

NO 0.120*10^3 0.128*10^3


先对字符串进行简化,再比较,输出。比先比较,再化简的要简便很多。

#include<iostream>
#include<string>
using namespace std;
int t;
struct node{
    string s,num;
    int e;
    void fuc(){
        e=0;
        while(s[0]=='0'){
            s.erase(s.begin());
        }
        if(s[0]=='.'){
            s.erase(s.begin());
            while(s[0]=='0'){
                e--;
                s.erase(s.begin());
            }
            num=s.substr(0,s.size());
        }
        else{
            while(s[0]!='.'&&s.size()>=1){
                e++;
                num+=s[0];
                s.erase(s.begin());
            }
            if(s[0]=='.'){
                s.erase(s.begin());
            }
            if(s.size()>0){
                num+=s;
            }
        }
        if(num.size()>t){
            num=num.substr(0,t);
        }
        else{
            while(num.size()<t){
                num+="0";
            }
        }
    }
    void print(){
        cout<<"0."<<num;
         printf("*10^%d",e);
    }
};
int main(){
    node a,b;
    cin>>t>>a.s>>b.s;
    a.fuc(),b.fuc();
    if(a.num==b.num&&a.e==b.e){
        printf("YES ");
        a.print();
    }
    else {
        printf("NO ");
        a.print();
        printf(" ");
        b.print();
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值