1105. Spiral Matrix (25)

时间限制
150 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

This time your job is to fill a sequence of N positive integers into a spiral matrix in non-increasing order. A spiral matrix is filled in from the first element at the upper-left corner, then move in a clockwise spiral. The matrix has m rows and n columns, where m and n satisfy the following: m*n must be equal to N; m>=n; and m-n is the minimum of all the possible values.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N. Then the next line contains N positive integers to be filled into the spiral matrix. All the numbers are no more than 104. The numbers in a line are separated by spaces.

Output Specification:

For each test case, output the resulting matrix in m lines, each contains n numbers. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.
Sample Input:

12
37 76 20 98 76 42 53 95 60 81 58 93

Sample Output:

98 95 93
42 37 81
53 20 76
58 60 76


注意控制好移动轨迹。
ni,nj是下次准备移动的目标点,若目标的越界或者已经赋值,则转向。

if(b[ni][nj]==-1&&ni<m&&nj<n&&ni>=0&&nj>=0){
            i=ni,j=nj;
            b[i][j]=a[cnt];
            ni+=w[c%4][0],nj+=w[c%4][1];
            cnt++;
        }
        else{
            c++;
            ni=i+w[c%4][0],nj=j+w[c%4][1];
        }

#include<iostream>
#include<algorithm>
#include<vector>
using namespace std;
int w[4][2]={{0,1},{1,0},{0,-1},{-1,0}};
bool cmp(int a,int b){
    return a>b;
}
int main(){
    freopen("in.txt","r",stdin);
    int N,x,b[110][110];
    fill(b[0],b[0]+110*110,-1);
    scanf("%d",&N);
    vector<int> a(N);
    for(int i=0;i<N;i++){
        scanf("%d",&a[i]);
    }
    sort(a.begin(),a.end(),cmp);
    int m=N,n=1;
    for(int i=1;i<=N;i++){
        if(N%i==0&&i>=(N/i)){
            m=i,n=N/i;
            break;
        }
    }
    int i,j,cnt=0,c=0,ni=0,nj=0;
    while(cnt<N){
        if(b[ni][nj]==-1&&ni<m&&nj<n&&ni>=0&&nj>=0){
            i=ni,j=nj;
            b[i][j]=a[cnt];
            ni+=w[c%4][0],nj+=w[c%4][1];
            cnt++;
        }
        else{
            c++;
            ni=i+w[c%4][0],nj=j+w[c%4][1];
        }
    }
    for(i=0;i<m;i++){
        printf("%d",b[i][0]);
        for(j=1;j<n;j++){
            printf(" %d",b[i][j]);
        }
        printf("\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值