UVA 704 Colour Hash (双向bfs + 判重)


 Colour Hash 

This puzzle consists of two wheels. Both wheels can rotate both clock and counter-clockwise. They contain 21 coloured pieces, 10 of which are rounded triangles and 11 of which are separators. Figure 1 shows the final position of each one of the pieces. Note that to perform a one step rotation you must turn the wheel until you have advanced a triangle and a separator.


Figure 1. Final puzzle configuration

Your job is to write a program that reads the puzzle configuration and prints the minimum sequence of movements required to reach the final position. We will use the following integer values to encode each type of piece:


0grey separator
1yellow triangle
2yellow separator
3cyan triangle
4cyan separator
5violet triangle
6violet separator
7green triangle
8green separator
9red triangle
10red separator


A puzzle configuration will be described using 24 integers, the first 12 to describe the left wheel configuration and the last 12 for the right wheel. The first integer represents the bottom right separator of the left wheel and the next eleven integers describe the left wheel clockwise. The thirteenth integer represents the bottom left separator of right wheel and the next eleven integers describe the right wheel counter-clockwise.

The final position is therefore encoded like:

0 3 4 3 0 5 6 5 0 1 2 1 0 7 8 7 0 9 10 9 0 1 2 1

If for instance we rotate the left wheel clockwise one position from the final configuration (as shown in Figure 2) the puzzle configuration would be encoded like:

2 1 0 3 4 3 0 5 6 5 0 1 0 7 8 7 0 9 10 9 0 5 0 1


Figure 2. The puzzle after rotating the left wheel on step clockwise from the final configuration.

Input 

Input for your program consists of several puzzles. The first line of the input will contain an integer n specifying the number of puzzles. There will then be n lines each containing 24 integers separated with one white space, describing the initial puzzle configuration as explained above.

Output 

For each configuration your program should output one line with just one number representing the solution. Each movement is encoded using one digit from 1 to 4 in the following way:


1Left Wheel Clockwise rotation
2Right Wheel Clockwise rotation
3Left Wheel Counter-Clockwise rotation
4Right Wheel Counter-Clockwise rotation


No space should be printed between each digit. Since multiple solutions could be found, you should print the solution that is encoded as the smallest number. The solution will never require more than 16 movements.

If no solution is found you should print ``NO SOLUTION WAS FOUND IN 16 STEPS". If you are given the final position you should print ``PUZZLE ALREADY SOLVED".

Sample Input 

3
0 3 4 3 0 5 6 5 0 1 2 1 0 7 8 7 0 9 10 9 0 1 2 1
0 3 4 5 0 3 6 5 0 1 2 1 0 7 8 7 0 9 10 9 0 1 2 1
0 9 4 3 0 5 6 5 0 1 2 1 0 7 8 7 0 9 10 3 0 1 2 1

Sample Output 

PUZZLE ALREADY SOLVED
1434332334332323
NO SOLUTION WAS FOUND IN 16 STEPS

题意:给定一个状态。要转到0343056501210787091090121这个状态。求最少转的步骤。。如果超过16步不记。如果第一步就成功了就直接输出PUZZLE ALREADY SOLVED。

思路:双向BFS。从终点状态往前转8步。记录下这些状态。然后从起点往后转8步。看8步内能不能出现其中的状态。如果可以就是可以转出。最后输出的时候要注意。由于从终点往前转的全部都是逆过来的。输出全部要逆过来(包括顺序和顺逆时针)..

代码:

#include <stdio.h>
#include <string.h>
#include <string>
#include <map>
#include <queue>
#include <iostream>
using namespace std;

int t;
int judge;
char pu[30];
char start[30] = "034305650121078709:90121";
struct QUE {
    char status[30];
    char step[30];
    int stepnum;
} q, p;
map<string, string> vis;
map<string, int> viss;
queue<QUE> Q;

void zhuan(int way) {
    if (way == 1) {
	char sb1 = q.status[10];
	char sb2 = q.status[11];
	for (int i = 11; i >= 2; i --)
	    q.status[i] = q.status[i - 2];
	q.status[1] = sb2; q.status[0] = sb1;
	q.status[23] = q.status[11]; 
	q.status[22] = q.status[10];
	q.status[21] = q.status[9];
    }
    if (way == 3) {
	char sb1 = q.status[0];
	char sb2 = q.status[1];
	for (int i = 0; i < 10; i ++)
	    q.status[i] = q.status[i + 2];
	q.status[11] = sb2; q.status[10] = sb1;
	q.status[23] = q.status[11]; 
	q.status[22] = q.status[10];
	q.status[21] = q.status[9];
    }
    if (way == 4) {
	char sb1 = q.status[22];
	char sb2 = q.status[23];
	for (int i = 23; i >= 12; i --)
	    q.status[i] = q.status[i - 2];
	q.status[13] = sb2; q.status[12] = sb1;
	q.status[11] = q.status[23]; 
	q.status[10] = q.status[22];
	q.status[9] = q.status[21];

    }
    if (way == 2) {
	char sb1 = q.status[12];
	char sb2 = q.status[13];
	for (int i = 12; i < 22; i ++)
	    q.status[i] = q.status[i + 2];
	q.status[23] = sb2; q.status[22] = sb1;
	q.status[11] = q.status[23]; 
	q.status[10] = q.status[22];
	q.status[9] = q.status[21];

    }
}
void bfs(char *a) {
    vis.clear();
    while (!Q.empty()) {Q.pop();}
    strcpy(q.status, a); q.stepnum = 0; q.step[0] = '\0';
    vis[q.status] = "sb";
    Q.push(q);
    while (!Q.empty()) {
	p = Q.front();
	Q.pop();
	for (int i = 1; i <= 4; i ++) {
	    q = p;
	    zhuan(i);
	    if (vis[q.status] == "") {
		q.step[q.stepnum ++] = i + '0';
		q.step[q.stepnum] = '\0';
		vis[q.status] = q.step;
		Q.push(q);
	    }
	}
	if (p.stepnum == 8)
	    return;	    
    }
}

void bfs2(char *a) {
    viss.clear();
    while (!Q.empty()) {Q.pop();}
    strcpy(q.status, a); q.stepnum = 0; q.step[0] = '\0';
    viss[q.status] = 1;
    Q.push(q);
    while (!Q.empty()) {
	p = Q.front();
	if (vis[p.status] != "") {
	    judge = 1;
	    return;
	}
	Q.pop();
	for (int i = 1; i <= 4; i ++) {
	    q = p;
	    zhuan(i);
	    if (viss[q.status] == 0) {
		q.step[q.stepnum ++] = i + '0';
		q.step[q.stepnum] = '\0';
		viss[q.status] = 1;
		Q.push(q);
	    }
	}
	if (p.stepnum == 9)
	    return;
    }
}

int main() {
    scanf("%d%*c", &t);
    while (t --) {
	int piece;
	judge = 0;
	for (int i = 0; i < 24; i ++) {
	    scanf("%d", &piece);
	    pu[i] = '0' + piece;
	}
	pu[24] = '\0';
	if (strcmp(pu, start) == 0) {
	    printf("PUZZLE ALREADY SOLVED\n");
	    continue;
	}
	bfs(start);
	bfs2(pu);
	if (judge) {
	    printf("%s", p.step);
	    for (int i = vis[p.status].size() - 1; i >= 0; i --) {
		if (vis[p.status][i] == '1') printf("3");
		if (vis[p.status][i] == '2') printf("4");
		if (vis[p.status][i] == '3') printf("1");
		if (vis[p.status][i] == '4') printf("2");
	    }
	    printf("\n");
	}
	else printf("NO SOLUTION WAS FOUND IN 16 STEPS\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
城市应急指挥系统是智慧城市建设的重要组成部分,旨在提高城市对突发事件的预防和处置能力。系统背景源于自然灾害和事故灾难频发,如汶川地震和日本大地震等,这些事件造成了巨大的人员伤亡和财产损失。随着城市化进程的加快,应急信息化建设面临信息资源分散、管理标准不统一等问题,需要通过统筹管理和技术创新来解决。 系统的设计思路是通过先进的技术手段,如物联网、射频识别、卫星定位等,构建一个具有强大信息感知和通信能力的网络和平台。这将促进不同部门和层次之间的信息共享、交流和整合,提高城市资源的利用效率,满足城市对各种信息的获取和使用需求。在“十二五”期间,应急信息化工作将依托这些技术,实现动态监控、风险管理、预警以及统一指挥调度。 应急指挥系统的建设目标是实现快速有效的应对各种突发事件,保障人民生命财产安全,减少社会危害和经济损失。系统将包括预测预警、模拟演练、辅助决策、态势分析等功能,以及应急值守、预案管理、GIS应用等基本应用。此外,还包括支撑平台的建设,如接警中心、视频会议、统一通信等基础设施。 系统的实施将涉及到应急网络建设、应急指挥、视频监控、卫星通信等多个方面。通过高度集成的系统,建立统一的信息接收和处理平台,实现多渠道接入和融合指挥调度。此外,还包括应急指挥中心基础平台建设、固定和移动应急指挥通信系统建设,以及应急队伍建设,确保能够迅速响应并有效处置各类突发事件。 项目的意义在于,它不仅是提升灾害监测预报水平和预警能力的重要科技支撑,也是实现预防和减轻重大灾害和事故损失的关键。通过实施城市应急指挥系统,可以加强社会管理和公共服务,构建和谐社会,为打造平安城市提供坚实的基础。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值