2017icpc-beijing-j(pangu and stone)

同学去的比赛,j题是个dp就补了一下

原题:点击打开链接

#1636 : Pangu and Stones

时间限制: 1000ms
单点时限: 1000ms
内存限制: 256MB

描述

In Chinese mythology, Pangu is the first living being and the creator of the sky and the earth. He woke up from an egg and split the egg into two parts: the sky and the earth.

At the beginning, there was no mountain on the earth, only stones all over the land.

There were N piles of stones, numbered from 1 to N. Pangu wanted to merge all of them into one pile to build a great mountain. If the sum of stones of some piles was S, Pangu would need S seconds to pile them into one pile, and there would be S stones in the new pile.

Unfortunately, every time Pangu could only merge successive piles into one pile. And the number of piles he merged shouldn't be less than L or greater than R.

Pangu wanted to finish this as soon as possible.

Can you help him? If there was no solution, you should answer '0'.

输入

There are multiple test cases.

The first line of each case contains three integers N,L,R as above mentioned (2<=N<=100,2<=L<=R<=N).

The second line of each case contains N integers a1,a2 …aN (1<= ai  <=1000,i= 1…N ), indicating the number of stones of  pile 1, pile 2 …pile N.

The number of test cases is less than 110 and there are at most 5 test cases in which N >= 50.

输出

For each test case, you should output the minimum time(in seconds) Pangu had to take . If it was impossible for Pangu to do his job, you should output  0.

样例输入
3 2 2
1 2 3
3 2 3
1 2 3
4 3 3
1 2 3 4
样例输出
9
6
0
题目大意:

求要把石子堆合并成一堆所需的最少时间,一次合并最少可以合并L个最多可以合并R个,合并所需时间为石子堆石子的和

输入:

3 2 2  //3个石子堆,最少合并2堆,最多合并2堆
1 2 3  //第一个石子堆有1个石头,第二个2个,第三个3个
9  //最少所需时间为9

思路:

区间dp的变形

用dp[i][j][k]表示将区间i~j的石子堆合并成k堆所需的最少时间

好难用语言表示出来,我把代码贴出来可能会好说一点

for(int len=2;len<=N;len++)  //len表示的是i~i+len的长度
        {
            for(int i=0;i+len-1<=N-1;i++)   //i表示当前区间的起点
            {
                for(int j=i;j<=i+len-1;j++)     //j表示当前区间中间的某一个点
                {
                    for(int k=l;k<=r;k++)       //这里的k表示的是这一次能够将k块合并成一块
                    {
                        dp[i][i+len-1][1]=min(dp[i][j][k-1]+dp[j+1][i+len-1][1]+sum[i+len-1]-sum[i],dp[i][i+len-1][1]);
                    }   //dp[i][j][1]的转移方程,因为一次要将k块合并成一块,所以要把区间i~i+len分解成k块即k-1与1;
                }
                for(int j=2;j<=len;j++)    //注意这里的j表示的是要将区间合并成j块
                {
                    for(int k=i;k<=i+len-1;k++)  //这里的k表示当前区间中间的某一个点
                    {
                        dp[i][i+len-1][j]=min(dp[i][k][j-1]+dp[k+1][i+len-1][1],dp[i][i+len-1][j]);
 			//dp[i][j][k]的转移方程
                    }
                }
            }
        }


完整代码如下:

#include<bits/stdc++.h>  
#define P pair<int,int>  
#define N 105  
using namespace std;  
typedef long long ll;  
const int inf=1e9+7;  
const ll M=19260817;  
int dp[N][N][N],sum[N];  
int main()  
{  
    int n,l,r;  
    while(~scanf("%d%d%d",&n,&l,&r))  
    {  
        for(int i=1;i<=n;i++){  
            scanf("%d",&sum[i]);  
            sum[i]+=sum[i-1];  
        }  
        for(int i=0;i<=n;i++)  
            for(int j=0;j<=n;j++)  
                for(int k=0;k<=n;k++)  
                    dp[i][j][k]=inf;  
        for(int i=1;i<=n;i++)  
            for(int j=i;j<=n;j++)  
                dp[i][j][j-i+1]=0;  
        for(int d=1;d<n;d++){  
            for(int i=1;i+d<=n;i++){  
                for(int j=i;j<i+d;j++)  
                    for(int k=l-1;k<r;k++)  
                        dp[i][i+d][1]=min(dp[i][i+d][1],dp[i][j][k]+dp[j+1][i+d][1]+sum[i+d]-sum[i-1]);  
                for(int j=2;j<=d;j++)  
                    for(int k=i;k<i+d;k++)  
                        dp[i][i+d][j]=min(dp[i][i+d][j],dp[i][k][j-1]+dp[k+1][i+d][1]);  
            }  
        }  
        if(dp[1][n][1]==inf)dp[1][n][1]=0;  
        printf("%d\n",dp[1][n][1]);  
    }  
    return 0;  
}  


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值