ZOJ - 1093 Monkey and Banana

Time Limit: 2000MS Memory Limit: 65536KB 64bit IO Format: %lld & %llu

[]   [Go Back]   [Status]  

Description

A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height.

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked.

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.

Input Specification

The input file will contain one or more test cases. The first line of each test case contains an integer  n
representing the number of different blocks in the following data set. The maximum value for  n is 30. 
Each of the next  n lines contains three integers representing the values  xiyi and  zi
Input is terminated by a value of zero (0) for  n.

Output Specification

For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case  case: maximum height =  height"

Sample Input

1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0

Sample Output

Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342
 
  
 
  
 
  
 
  
简单的dp题。
 
  
分析:因为每块积木最多有3个不同的底面和高度,因此先把每块积木看成三种不同的积木,每种积木只有一个底面和一个高度。n种类型的积木转化为3*n个不同的积木的叠加,对这3 * n个积木的长边从大到小排序;接下来的问题就是找到一个递减的子序列,使得子序列的高度和最大即可。


数组dp:dp[i]表示是以第i块积木为顶的塔的最大高度


因此可得状态转移方程:dp[i] = max(dp[i],dp[j] + r[i].z)(满足积木j的底面长和宽都大于积木i的长和宽)
 
  
 
  
 
  
 
  
代码:
#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
int n;
struct R
{
    int x,y,z;
}r[100];
int dp[100];
bool cmp(const R a,const R b)
{
    if(a.x==b.x) return a.y>b.y;
    else return a.x>b.x;
}
int DP()
{
    int maxh=0,i,j;
    sort(r,r+n,cmp);
    for(i=0;i<n;i++)
    {
        dp[i]=r[i].z;
        for(j=i-1;j>=0;j--)
            if(r[j].x>r[i].x&&r[j].y>r[i].y)
            if(dp[j]+r[i].z>dp[i])
            dp[i]= dp[j]+r[i].z;
        maxh=maxh>dp[i]?maxh:dp[i];
    }
    return maxh;
}


int main()
{
    int i,j,a,b,c,kase=0;
    while(scanf("%d",&n)&&n!=0)
    {
        for(i=0,j=0;i<n;i++)
        {
           scanf("%d%d%d",&a,&b,&c);
           r[j].x=min(a,b);
           r[j].y=max(a,b);
           r[j].z=c;
           r[j+1].x=min(a,c);
           r[j+1].y=max(a,c);
           r[j+1].z=b;
           r[j+2].x=min(b,c);
           r[j+2].y=max(b,c);
           r[j+2].z=a;
           j+=3;
        }
        n=j;
        printf("Case %d: maximum height = %d\n",++kase,DP());
    }
    return 0;
}




 
 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
基于微信小程序的家政服务预约系统采用PHP语言和微信小程序技术,数据库采用Mysql,运行软件为微信开发者工具。本系统实现了管理员和客户、员工三个角色的功能。管理员的功能为客户管理、员工管理、家政服务管理、服务预约管理、员工风采管理、客户需求管理、接单管理等。客户的功能为查看家政服务进行预约和发布自己的需求以及管理预约信息和接单信息等。员工可以查看预约信息和进行接单。本系统实现了网上预约家政服务的流程化管理,可以帮助工作人员的管理工作和帮助客户查询家政服务的相关信息,改变了客户找家政服务的方式,提高了预约家政服务的效率。 本系统是针对网上预约家政服务开发的工作管理系统,包括到所有的工作内容。可以使网上预约家政服务的工作合理化和流程化。本系统包括手机端设计和电脑端设计,有界面和数据库。本系统的使用角色分为管理员和客户、员工三个身份。管理员可以管理系统里的所有信息。员工可以发布服务信息和查询客户的需求进行接单。客户可以发布需求和预约家政服务以及管理预约信息、接单信息。 本功能可以实现家政服务信息的查询和删除,管理员添加家政服务信息功能填写正确的信息就可以实现家政服务信息的添加,点击家政服务信息管理功能可以看到基于微信小程序的家政服务预约系统里所有家政服务的信息,在添加家政服务信息的界面里需要填写标题信息,当信息填写不正确就会造成家政服务信息添加失败。员工风采信息可以使客户更好的了解员工。员工风采信息管理的流程为,管理员点击员工风采信息管理功能,查看员工风采信息,点击员工风采信息添加功能,输入员工风采信息然后点击提交按钮就可以完成员工风采信息的添加。客户需求信息关系着客户的家政服务预约,管理员可以查询和修改客户需求信息,还可以查看客户需求的添加时间。接单信息属于本系统里的核心数据,管理员可以对接单的信息进行查询。本功能设计的目的可以使家政服务进行及时的安排。管理员可以查询员工信息,可以进行修改删除。 客户可以查看自己的预约和修改自己的资料并发布需求以及管理接单信息等。 在首页里可以看到管理员添加和管理的信息,客户可以在首页里进行家政服务的预约和公司介绍信息的了解。 员工可以查询客户需求进行接单以及管理家政服务信息和留言信息、收藏信息等。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值