zoj2988 Conversions

Time Limit: 2000MS Memory Limit: 65536KB 64bit IO Format: %lld & %llu

 Status

Description

Conversion between the metric and English measurement systems is relatively simple. Often, it involves either multiplying or dividing by a constant. You must write a program that converts between the following units:

TypeMetricEnglishequivalent
Weight1.000kilograms2.2046 pounds
Weight0.4536kilograms1.0000 pound
Volume1.0000liter0.2642 gallons
Volume3.7854liters1.0000 gallon

Input

The first line of input contains a single integer N, (1 <= N <= 1000) which is the number of datasets that follow.

Each dataset consists of a single line of input containing a floating point (double precision) number, a space and the unit specification for the measurement to be converted. The unit specification is one of kg, lb, l, or g referring to kilograms, pounds, liters and gallons respectively.

Output

For each dataset, you should generate one line of output with the following values: The dataset number as a decimal integer (start counting at one), a space, and the appropriately converted value rounded to 4 decimal places, a space and the unit specification for the converted value.

Sample Input

5
1 kg
2 l
7 lb
3.5 g
0 l

Sample Output

1 2.2046 lb
2 0.5284 g
3 3.1752 kg
4 13.2489 l
5 0.0000 g




Source

Greater New York Region 2007
 
 
 
分析:
水题。
ac代码:

#include <iostream>
#include<cstdio>
#include<cstring>
using namespace std;

int main()
{
    int n,i,t=0;
    double x;
    char c[5];
    scanf("%d",&n);
    while(n--)
    {
        scanf("%lf",&x);
        scanf("%s",c);//这样不会读取到空格
        printf("%d ",++t);
        if(!strcmp(c,"kg"))
        {
            printf("%.4lf lb\n",2.2046*x);
        }
          else if(!strcmp(c,"lb"))
        {
            printf("%.4lf kg\n",0.4536*x);
        }
          else if(!strcmp(c,"l"))
        {
            printf("%.4lf g\n",0.2642*x);
        }
          else if(!strcmp(c,"g"))
        {
            printf("%.4lf l\n",3.7854*x);
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值