3005. Conversions

用乘的,用除法会出错

Conversion between the metric and English measurement systems is relatively simple. Often, it involves either multiplying or dividing by a constant. You must write a program that converts between the following units:

Input

The first line of input contains a single integer N, (1 ≤ N ≤ 1000) which is the number of datasets that follow.

Each dataset consists of a single line of input containing a floating point (double precision) number, a space and the unit specification for the measurement to be converted. The unit specification is one of kg, lb, l, or g referring to kilograms, pounds, liters and gallons respectively.

Output

For each dataset, you should generate one line of output with the following values: The dataset number as a decimal integer (start counting at one), a space, and the appropriately converted value rounded to 4 decimal places, a space and the unit specification for the converted value.

Sample Input

5
1 kg
2 l
7 lb
3.5 g
0 l

Sample Output

1 2.2046 lb
2 0.5284 g
3 3.1752 kg
4 13.2489 l
5 0.0000 g
#include<iostream>
#include<string>
#include<iomanip>
using namespace std;
const float f1=2.2046;
const float f2=0.2642;
const float f3=0.4536;
const float f4=3.7854;
int main(){
	int n,i;
	float a,b;
	string s;
	cin>>n;
	for(i=1;i<=n;i++){
		cin>>a>>s;
	//	cout<<a<<endl;
		//cout<<s;
		cout<<i<<" ";
		if(s=="kg"){
			b=a*f1;
			cout<<fixed<<setprecision(4)<<b<<" lb"<<endl;
		}
		else if(s=="l")
		{
			b=a*f2;
			cout<<fixed<<setprecision(4)<<b<<" g"<<endl;
		}
		else if(s=="lb")
		{
			//b=a/f1;
			cout<<fixed<<setprecision(4)<<a*f3<<" kg"<<endl;
		}
		else if(s=="g"){
			//b=a/f2;
			cout<<fixed<<setprecision(4)<<a*f4<<" l"<<endl;
		}
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值