hdu 1985

Conversions

Time Limit: 1000/500 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1124    Accepted Submission(s): 647


Problem Description
Conversion between the metric and English measurement systems is relatively simple. Often, it involves either multiplying or dividing by a constant. You must write a program that converts between the following units:

 

Input
The first line of input contains a single integer N, (1 ≤ N ≤ 1000) which is the number of datasets that follow.
Each dataset consists of a single line of input containing a floating point (double precision) number, a space and the unit specification for the measurement to be converted. The unit specification is one of kg, lb, l, or g referring to kilograms, pounds, liters and gallons respectively.
 

Output
For each dataset, you should generate one line of output with the following values: The dataset number as a decimal integer (start counting at one), a space, and the appropriately converted value rounded to 4 decimal places, a space and the unit specification for the converted value.

 

Sample Input
  
  
5 1 kg 2 l 7 lb 3.5 g 0 l
 

Sample Output
  
  
1 2.2046 lb 2 0.5284 g 3 3.1752 kg 4 13.2489 l 5 0.0000 g
 

Source
 

Recommend
linle
 
//该题就是简单的单位换算
#include <stdio.h>
#include <string.h>
int main()
{
	int n, i;
	double in;
	char c[3];
	scanf("%d", &n);
	for (i = 1; i <= n; i++)
	{
		scanf("%lf%s", &in, c);
		if (strcmp(c, "kg") == 0)
			printf("%d %.4lf lb\n", i, in*2.2046);
		else if (strcmp(c, "lb") == 0)
			printf("%d %.4lf kg\n", i, in*0.4536);
		else if (strcmp(c, "l") == 0)
			printf("%d %.4lf g\n", i, in*0.2642);
		else if (strcmp(c, "g") == 0)
			printf("%d %.4lf l\n", i, in*3.7854);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值