hdu 5455 Fang Fang(字符串处理)

Fang Fang

Time Limit: 1500/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 1317    Accepted Submission(s): 548


Problem Description
Fang Fang says she wants to be remembered.
I promise her. We define the sequence  F  of strings.
F0 = f",
F1 = ff",
F2 = cff",
Fn = Fn1 + f", for n > 2
Write down a serenade as a lowercase string  S  in a circle, in a loop that never ends.
Spell the serenade using the minimum number of strings in  F , or nothing could be done but put her away in cold wilderness.
 

Input
An positive integer  T , indicating there are  T  test cases.
Following are  T  lines, each line contains an string  S  as introduced above.
The total length of strings for all test cases would not be larger than  106 .
 

Output
The output contains exactly  T  lines.
For each test case, if one can not spell the serenade by using the strings in  F , output  1 . Otherwise, output the minimum number of strings in  F  to split  S according to aforementioned rules. Repetitive strings should be counted repeatedly.
 

Sample Input
  
  
8 ffcfffcffcff cffcfff cffcff cffcf ffffcffcfff cffcfffcffffcfffff cff cffc
 

Sample Output
  
  
Case #1: 3 Case #2: 2 Case #3: 2 Case #4: -1 Case #5: 2 Case #6: 4 Case #7: 1 Case #8: -1
Hint
Shift the string in the first test case, we will get the string "cffffcfffcff" and it can be split into "cffff", "cfff" and "cff".
题意:串可以由f,ff,cff,或者cffffffffffffffffffffffff组成,串是循环串,合法则输出最少有几串,不合法输出-1

思路:直接处理

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
char str[1000010];
int main()
{
    int T;
    scanf("%d",&T);
    for(int t=1; t<=T; t++)
    {
        scanf("%s",str);
        int len=strlen(str);
        int l=0,r=len-1,num=0;
        if(len<3)
        {
            if(len==1&&str[0]=='f')
            printf("Case #%d: 1\n",t);
            else if(len==2&&str[0]=='f'&&str[1]=='f')
            printf("Case #%d: 1\n",t);
            else printf("Case #%d: -1\n",t);
                continue;
        }
        if(str[l]=='f')
        {
            num=1;
            while(r>=0&&str[r]=='f')
                r--;
            while(l<len&&str[l]=='f')
                l++;
            if(r<0)
            {
                printf("Case #%d: %d\n",t,len%2==0?len/2:len/2+1);
                continue;
            }
            else if(r==len-1&&l==1)
            {
                printf("Case #%d: -1\n",t);
                continue;
            }
            else if(l==r&&r==len-1)
            {
                printf("Case #%d: 1\n",t);
                continue;
            }
            r--;
        }
        int flag=0;
        while(l<=r)
        {
            num++;
            if(str[l]=='c')
            {
                int q=0;
                l++;
                while(l<=r&&str[l]=='f')
                {
                    q++;
                    l++;
                }
                if(q<2)
                {
                    flag=1;
                    break;
                }
                if(l>r) break;
            }
            else
            {
                flag=1;
                break;
            }
        }
        if(flag) printf("Case #%d: -1\n",t);
        else printf("Case #%d: %d\n",t,num);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值