hdu 5019 Revenge of GCD(数论,枚举)

Revenge of GCD

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2130    Accepted Submission(s): 592


Problem Description
In mathematics, the greatest common divisor (gcd), also known as the greatest common factor (gcf), highest common factor (hcf), or greatest common measure (gcm), of two or more integers (when at least one of them is not zero), is the largest positive integer that divides the numbers without a remainder.
---Wikipedia

Today, GCD takes revenge on you. You have to figure out the k-th GCD of X and Y.
 

Input
The first line contains a single integer T, indicating the number of test cases. 

Each test case only contains three integers X, Y and K.

[Technical Specification]
1. 1 <= T <= 100
2. 1 <= X, Y, K <= 1 000 000 000 000
 

Output
For each test case, output the k-th GCD of X and Y. If no such integer exists, output -1.
 

Sample Input
  
  
3 2 3 1 2 3 2 8 16 3
 

Sample Output
  
  
1 -1 2
题意:问你x和y的第k大公约数

思路:此题虽然很水,但是我却卡了很久。。  一直以为枚举会炸掉,所以想从gcd的所有质因子入手,却发现怎么也不能找到所有情况

后来试着枚举居然AC了- -   还是做题经验不够。注意不能直接从公约数到1进行枚举,所有的约数分为小于sqrt(gcd(x,y))的和大于sqrt(gcd(x,y))的

我们只需要求两次1~sqrt(gcd(x,y))即可  

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
#define LL long long
#define N 10000000
LL e[N][2],vis[N];
LL cnt;
LL gcd(LL a,LL b)
{
    return b?gcd(b,a%b):a;
}
int main()
{
    LL x,y,k;
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%lld %lld %lld",&x,&y,&k);
        LL t=gcd(x,y);
        LL num=0,v;
        for(LL i=1; i*i<=t; i++)
        {
            if(t%i==0)
            {
                num++;
                v=t/i;
            }
            if(num==k) break;
        }
        if(num==k) printf("%lld\n",v);
        else
        {
            for(LL i=sqrt(t); i>=1; i--)
            {
                if(i*i==t) continue;
                if(t%i==0)
                {
                    num++;
                    v=i;
                }
                if(num==k) break;
            }
            if(num==k) printf("%lld\n",v);
            else printf("-1\n");
        }
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值