HDU 5019 Revenge of GCD(简单枚举)

Revenge of GCD

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)


Problem Description
In mathematics, the greatest common divisor (gcd), also known as the greatest common factor (gcf), highest common factor (hcf), or greatest common measure (gcm), of two or more integers (when at least one of them is not zero), is the largest positive integer that divides the numbers without a remainder.
---Wikipedia

Today, GCD takes revenge on you. You have to figure out the k-th GCD of X and Y.
 

Input
The first line contains a single integer T, indicating the number of test cases. 

Each test case only contains three integers X, Y and K.

[Technical Specification]
1. 1 <= T <= 100
2. 1 <= X, Y, K <= 1 000 000 000 000
 

Output
For each test case, output the k-th GCD of X and Y. If no such integer exists, output -1.
 

Sample Input
  
  
3 2 3 1 2 3 2 8 16 3
 

Sample Output
  
  
1 -1 2
 

Source
 

题目大意:求X和Y的第K大公约数,如果不存在,输出-1。


解题思路:X 和Y的gcd一定是X和Y的第一大公约数,如果X和Y的第K大公约数存在,那么这个数一定是gcd(X,Y)的约数,因此枚举gcd(X,Y)的约数,判断是否存在第K大约数。


代码如下:

#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <ctime>
#include <iostream>
#include <algorithm>
#include <string>
#include <vector>
#include <deque>
#include <list>
#include <set>
#include <map>
#include <stack>
#include <queue>
#include <numeric>
#include <iomanip>
#include <bitset>
#include <sstream>
#include <fstream>
#include <limits.h>
#define debug "output for debug\n"
#define pi (acos(-1.0))
#define eps (1e-6)
#define inf (1<<28)
#define sqr(x) (x) * (x)
#define mod 1000000007
using namespace std;
typedef long long ll;
typedef unsigned long long ULL;
bool cmp(const ll &a,const ll &b)
{
    return a>b;
}
ll gcd(ll a,ll b)
{
    return b?gcd(b,a%b):a;
}
vector<ll> s;
int main()
{
    ll i,j,a,x,y,k,t,num;
    scanf("%I64d",&t);
    while(t--)
    {
        scanf("%I64d%I64d%I64d",&x,&y,&k);
        s.clear();
        a=gcd(x,y);
        for(i=1;i*i<=a;i++)
        {
            if(a%i==0)
            {
                if(i*i!=a)
                {
                    s.push_back(i);
                    s.push_back(a/i);
                }
                else
                    s.push_back(i);
            }
        }
        if(k>s.size())
            printf("-1\n");
        else
        {
            sort(s.begin(),s.end(),cmp);
            printf("%I64d\n",s[k-1]);
        }
    }
    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值