杭电(hdu)5019 Revenge of GCD

Revenge of GCD

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1724    Accepted Submission(s): 472


Problem Description
In mathematics, the greatest common divisor (gcd), also known as the greatest common factor (gcf), highest common factor (hcf), or greatest common measure (gcm), of two or more integers (when at least one of them is not zero), is the largest positive integer that divides the numbers without a remainder.
---Wikipedia

Today, GCD takes revenge on you. You have to figure out the k-th GCD of X and Y.
 

Input
The first line contains a single integer T, indicating the number of test cases. 

Each test case only contains three integers X, Y and K.

[Technical Specification]
1. 1 <= T <= 100
2. 1 <= X, Y, K <= 1 000 000 000 000
 

Output
For each test case, output the k-th GCD of X and Y. If no such integer exists, output -1.
 

Sample Input
  
  
3 2 3 1 2 3 2 8 16 3
 

Sample Output
  
  
1 -1 2
 
本题大意:求出俩数的第k大的约数。
本题思想:我做这题的思想是先求出本题的最大公约数,再求出最大公约数所有的因子,用STL中set容器存储。使用反向迭代器,可求出第k大的因子。
代码如下:
#include <iostream>
#include <string>
#include <cmath>
#include <cstring>
#include <set>
typedef __int64 ll;
using namespace std;

set<ll> s;
ll GCD(ll xx,ll yy)
{
    ll r=1;
    while(r!=0)
    {
        r=xx%yy;
        xx=yy;
        yy=r;
    }
    return xx;
}

int main()
{
    int T;
    ll x,y,k,gcd,count;
    cin>>T;
    while(T--)
    {
        count=0;
        cin>>x>>y>>k;
        gcd=GCD(x,y);
        for(int i=1;i<=sqrt(gcd);i++)
        {
            if(gcd%i==0)
            {
                s.insert(i);
                s.insert(gcd/i);
            }
        }
        set<ll>::reverse_iterator rit;
        for(rit=s.rbegin();rit!=s.rend();rit++)
        {
            //cout<<*rit<<" ";
            count++;
            if(count==k)
            {
              cout<<*rit<<endl;
              break;
            }
        }
        if(count<k)cout<<"-1"<<endl;
        s.clear();
    }
    return 0;
}

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值