hdu 5150 Sum Sum Sum(判断素数)

Sum Sum Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1032    Accepted Submission(s): 611


Problem Description
We call a positive number  X  P-number if there is not a positive number that is less than  X  and the greatest common divisor of these two numbers is bigger than 1.
Now you are given a sequence of integers. You task is to calculate the sum of P-numbers of the sequence.
 

Input
There are several test cases. 
In each test case:
The first line contains a integer  N(1N1000) . The second line contains  N  integers. Each integer is between 1 and 1000.
 

Output
For each test case, output the sum of P-numbers of the sequence.
 

Sample Input
  
  
3 5 6 7 1 10
 

Sample Output
  
  
12 0
题意:给n个数,求其中素数之和

思路:打表素数筛选,判断素数,注意此题中1也要当成素数。 

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
using namespace std;
#define N 1050
int prime[N],notprime[N];
void init()
{
    prime[1]=1;
    for(int i=2;i<N;i++)
    {
        if(notprime[i]) continue;
        prime[i]=1;
        for(int j=i*i;j<N;j+=i)
            notprime[j]=1;
    }
}
int main()
{
    int n,t;
    init();
    while(~scanf("%d",&n))
    {
        long long ans=0;
        for(int i=0;i<n;i++)
        {
            scanf("%d",&t);
            if(prime[t]) ans+=t;
        }
        printf("%lld\n",ans);
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值