hdu 5176 The Experience of Love(并查集)

The Experience of Love

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 645    Accepted Submission(s): 216


Problem Description
A girl named Gorwin and a boy named Vivin is a couple. They arrived at a country named LOVE. The country consisting of  N  cities and only  N1  edges (just like a tree), every edge has a value means the distance of two cities. They select two cities to live,Gorwin living in a city and Vivin living in another. First date, Gorwin go to visit Vivin, she would write down the longest edge on this path(maxValue).Second date, Vivin go to Gorwin, he would write down the shortest edge on this path(minValue),then calculate the result of maxValue subtracts minValue as the experience of love, and then reselect two cities to live and calculate new experience of love, repeat again and again.

Please help them to calculate the sum of all experience of love after they have selected all cases.
 

Input
There will be about  5  cases in the input file.
For each test case the first line is a integer  N , Then follows  n1  lines, each line contains three integers  a b , and  c , indicating there is a edge connects city  a  and city  b  with distance  c .

[Technical Specification]
1<N<=150000,1<=a,b<=n,1<=c<=109
 

Output
For each case,the output should occupies exactly one line. The output format is Case #x: answer, here x is the data number, answer is the sum of experience of love.
 

Sample Input
  
  
3 1 2 1 2 3 2 5 1 2 2 2 3 5 2 4 7 3 5 4
 

Sample Output
  
  
Case #1: 1 Case #2: 17
Hint
huge input,fast IO method is recommended. In the first sample: The maxValue is 1 and minValue is 1 when they select city 1 and city 2, the experience of love is 0. The maxValue is 2 and minValue is 2 when they select city 2 and city 3, the experience of love is 0. The maxValue is 2 and minValue is 1 when they select city 1 and city 3, the experience of love is 1. so the sum of all experience is 1;

题意:给一棵树,求任意{两点路径上的最大边权值-最小边权值}的总和。 解法:sigma(maxVal[i]-minVal[i])=sigma(maxVal)-sigma(minVal)sigma(maxVal[i]minVal[i])=sigma(maxVal)sigma(minVal);所以我们分别求所有两点路径上的最大值的和,还有最小值的和。再相减就可以了。求最大值的和的方法用带权并查集,把边按权值从小到大排序,一条边一条边的算,当我们算第ii条边的时候权值为wiwi,两点是ui,viui,vi,前面加入的边权值一定是小于等于当前wiwi的,假设与uiui连通的点有aa个,与vivi连通的点有bb个,那么在aa个中选一个,在bb个中选一个,这两个点的路径上最大值一定是wiwi,一共有a*bab个选法,爱情经验值为a*b*wiabwi。 求最小值的和的方法类似。 槽点: 一:这题做数据的时候突然想到的把数据范围设在 unsigned long long 范围内,要爆 long long,这样选手在wa了之后可能心态不好找不到这个槽点,当是锻炼大家的心态和出现wa时的找错能力了,把这放在pretest..很良心的。 二,并查集的时候,用是递归的需要扩栈,一般上10w10w的递归都需要,所以看见有几个FST在栈溢出的,好桑心。

注意此题要用无符号长整形= = 150000*75000*75000*1000000000会爆long long

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <queue>
using namespace std;
#define N 200050
struct Edge
{
    unsigned long long u,v,w;
}edge[N];
int n;
unsigned long long f[N],num[N];
unsigned long long maxn,minn;
bool cmp(Edge a,Edge b)
{
    return a.w<b.w;
}
void init()
{
    for(int i=1;i<=n;i++)
    {
        f[i]=i;
        num[i]=1;
    }
}
unsigned long long finds(unsigned long long x)
{
    unsigned long long r=x;
    while(f[r]!=r)
        r=f[r];
    while(f[x]!=x)
    {
        unsigned long long m=x;
        x=f[x];
        f[m]=r;
    }
    return r;
}
void Union(int id,int flag)
{
    unsigned long long u=edge[id].u,v=edge[id].v,w=edge[id].w;
    unsigned long long x=finds(u),y=finds(v);
    if(flag) maxn+=num[x]*num[y]*w;
    else minn+=num[x]*num[y]*w;
    f[x]=y;
    num[y]+=num[x];
}
int main()
{
    int t=1;
    while(~scanf("%d",&n))
    {
        for(int i=1;i<n;i++)
            scanf("%I64u %I64u %I64u",&edge[i].u,&edge[i].v,&edge[i].w);
            sort(edge+1,edge+n,cmp);
        init();
        maxn=0,minn=0;
        for(int i=1;i<n;i++)
            Union(i,1);
        init();
        for(int i=n-1;i>=1;i--)
            Union(i,0);
        printf("Case #%d: %I64u\n",t++,maxn-minn);
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值