【BFS】Prime Path

10 篇文章 0 订阅

Prime Path

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 147    Accepted Submission(s): 94

Problem Description
The ministers of the cabinet were quite upset by the message from the Chief of Security stating that they would all have to change the four-digit room numbers on their offices. 
— It is a matter of security to change such things every now and then, to keep the enemy in the dark.
— But look, I have chosen my number 1033 for good reasons. I am the Prime minister, you know!
—I know, so therefore your new number 8179 is also a prime. You will just have to paste four new digits over the four old ones on your office door.
— No, it’s not that simple. Suppose that I change the first digit to an 8, then the number will read 8033 which is not a prime!
— I see, being the prime minister you cannot stand having a non-prime number on your door even for a few seconds.
— Correct! So I must invent a scheme for going from 1033 to 8179 by a path of prime numbers where only one digit is changed from one prime to the next prime.

Now, the minister of finance, who had been eavesdropping, intervened.
— No unnecessary expenditure, please! I happen to know that the price of a digit is one pound.
— Hmm, in that case I need a computer program to minimize the cost. You don’t know some very cheap software gurus, do you?
—In fact, I do. You see, there is this programming contest going on. . .

Help the prime minister to find the cheapest prime path between any two given four-digit primes! The first digit must be nonzero, of course. Here is a solution in the case above.
1033
1733
3733
3739
3779
8779
8179
The cost of this solution is 6 pounds. Note that the digit 1 which got pasted over in step 2 can not be reused in the last step – a new 1 must be purchased.
 

Input
One line with a positive number: the number of test cases (at most 100). Then for each test case, one line with two numbers separated by a blank. Both numbers are four-digit primes (without leading zeros).
 

Output
One line for each case, either with a number stating the minimal cost or containing the word Impossible.
 

Sample Input
  
  
3 1033 8179 1373 8017 1033 1033
 

Sample Output
  
  
6 7 0
 

Source

#include<cstdio>
#include<queue>
#include<cstring>
using namespace std;
int fa[10001];
int dir[4]= {10,100,1000,10000};
bool prime[10001],flag[10001];
int start,end;
int bfs(int x)
{
    int tot=0,son;
    bool ok=false;
    memset(flag,false,sizeof(flag));
    queue<int> q;
    q.push(x);
    for(; !q.empty();)
    {
        x=q.front();
        q.pop();
        for(int i=0; i<4; ++i)
        {
            for(int j=0; j<10; ++j)
            {
                if(i==3&&j==0) continue;
                son=j*dir[i]/10+(x/dir[i])*dir[i]+x%(dir[i]/10);
                if((!flag[son])&&(!prime[son])&&((son+2)%2!=0))
                {
                    q.push(son);
                    flag[son]=true;
                    fa[son]=x;
                    if(son==end)
                    {
                        ok=true;
                        break;
                    }
                }
            }
            if(ok) break;
        }
        if(ok) break;
    }
    for(; son!=start; ++tot,son=fa[son]);
    return tot;
}
int main()
{
    memset(prime,false,sizeof(prime));
    prime[0]=prime[1]=true;
    for(int i=3; i<10001; i+=2)
        for(int j=3; j<=i&&i*j<10001; j+=2)
            prime[i*j]=true;
    int n;
    for(; scanf("%d",&n)!=EOF;)
    {
        for(; n--;)
        {
            scanf("%d%d",&start,&end);
            printf("%d\n",bfs(start));
        }
    }
    return 0;
}

来源: http://blog.csdn.net/ACM_Ted

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值