HDOJ 1052 & UVA1344

46 篇文章 0 订阅

Tian Ji -- The Horse Racing

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13390    Accepted Submission(s): 3768


Problem Description
Here is a famous story in Chinese history.

"That was about 2300 years ago. General Tian Ji was a high official in the country Qi. He likes to play horse racing with the king and others."

"Both of Tian and the king have three horses in different classes, namely, regular, plus, and super. The rule is to have three rounds in a match; each of the horses must be used in one round. The winner of a single round takes two hundred silver dollars from the loser."

"Being the most powerful man in the country, the king has so nice horses that in each class his horse is better than Tian's. As a result, each time the king takes six hundred silver dollars from Tian."

"Tian Ji was not happy about that, until he met Sun Bin, one of the most famous generals in Chinese history. Using a little trick due to Sun, Tian Ji brought home two hundred silver dollars and such a grace in the next match."

"It was a rather simple trick. Using his regular class horse race against the super class from the king, they will certainly lose that round. But then his plus beat the king's regular, and his super beat the king's plus. What a simple trick. And how do you think of Tian Ji, the high ranked official in China?"



Were Tian Ji lives in nowadays, he will certainly laugh at himself. Even more, were he sitting in the ACM contest right now, he may discover that the horse racing problem can be simply viewed as finding the maximum matching in a bipartite graph. Draw Tian's horses on one side, and the king's horses on the other. Whenever one of Tian's horses can beat one from the king, we draw an edge between them, meaning we wish to establish this pair. Then, the problem of winning as many rounds as possible is just to find the maximum matching in this graph. If there are ties, the problem becomes more complicated, he needs to assign weights 0, 1, or -1 to all the possible edges, and find a maximum weighted perfect matching...

However, the horse racing problem is a very special case of bipartite matching. The graph is decided by the speed of the horses --- a vertex of higher speed always beat a vertex of lower speed. In this case, the weighted bipartite matching algorithm is a too advanced tool to deal with the problem.

In this problem, you are asked to write a program to solve this special case of matching problem.
 

Input
The input consists of up to 50 test cases. Each case starts with a positive integer n (n <= 1000) on the first line, which is the number of horses on each side. The next n integers on the second line are the speeds of Tian’s horses. Then the next n integers on the third line are the speeds of the king’s horses. The input ends with a line that has a single 0 after the last test case.
 

Output
For each input case, output a line containing a single number, which is the maximum money Tian Ji will get, in silver dollars.
 

Sample Input
  
  
3 92 83 71 95 87 74 2 20 20 20 20 2 20 19 22 18 0
 

Sample Output
  
  
200 0 0
 
其实一开始这道题挺困扰我的 , 大概经过了2-3次WA , 2次RE之后才把它A了哭
这道田忌赛马虽然是区域赛的原题,但是并不难,经常被选入各种新生赛 , 
这题的难点在于平局时该不该比。
比如:
3
92 83 71
95 92 74


3
92 83 70
92 91 60
显然第一组要打平局 , 第二组不要打平局
那么如何判断平局该不该打呢?
#include <iostream>
#include <cmath>
#include <cstdio>
#include <algorithm>
using namespace std;
int tj[1010] , king[1010];

int main()
{
    int  n  , i ,j , s , e;
    while(cin >> n , n)
    {
        for(i = 0 ; i < n ; i++)
        {
            cin >> tj[i];
        }
        for(i = 0 ; i < n ; i++)
        {
            cin >> king[i];
        }
        sort(tj , tj + n );
        sort(king , king + n);//将两人的马分别升序排列
        int cost = 0;
        i = s = 0 ;//当前状态下田忌和齐王最慢的马
        j = e = n - 1;//当前状态下田忌和齐王最快的马
        while(i <= j)
        {
            if(tj[i] > king[s])
            {
                cost ++;
                i ++;
                s ++;
            }
            else if(tj[i] < king[s])//向后移动田忌的马直到找到能胜过齐王的马
            {
                cost --;
                e -- ;//用田忌当前最慢的马比齐王最快的马
                i++;
            }
            else                     //出现平局
            {
                if(tj[j] > king[e])//如果田忌当前最快马大于齐王当前最快马,则让它们相比 
                {
                    cost ++;
                    e--;
                    j--;
                }
                else // 再也找不出可以赢齐王最快马的田忌马 , 用最慢马去消耗齐王的最快马
                {
                    if(tj[i] < king[e])//有平局就打
                    {
                        cost--;
                    }
                    e--;
                    i++;
                }

            }
        }

        cout << cost * 200 << endl;
    }
    return 0;
}
/*
3
71 83 92
74 92 95

3
70 83 92
60 91 92
*/
总体思路:用最慢马能干掉齐王最慢马,就去干 ,不行就去消耗齐王的最快马 , 有平局先不考虑 ,比较两人最快马 , 如果最快马能干掉齐王最快马 , 就去干 , 干不掉, 继续用最慢马消耗他的最快马。



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值