『1150」Travelling Salesman Problem

The “travelling salesman problem” asks the following question: “Given a list of cities and the distances between each pair of cities, what is the shortest possible route that visits each city and returns to the origin city?” It is an NP-hard problem in combinatorial optimization, important in operations research and theoretical computer science. (Quoted from “https://en.wikipedia.org/wiki/Travelling_salesman_problem".)

In this problem, you are supposed to find, from a given list of cycles, the one that is the closest to the solution of a travelling salesman problem.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (2<N≤200), the number of cities, and M, the number of edges in an undirected graph. Then M lines follow, each describes an edge in the format City1 City2 Dist, where the cities are numbered from 1 to N and the distance Dist is positive and is no more than 100. The next line gives a positive integer K which is the number of paths, followed by K lines of paths, each in the format:

n C1​ C2​ … Cn​

where n is the number of cities in the list, and Ci​’s are the cities on a path.

Output Specification:

For each path, print in a line Path X: TotalDist (Description) where X is the index (starting from 1) of that path, TotalDist its total distance (if this distance does not exist, output NA instead), and Description is one of the following:

  • TS simple cycle if it is a simple cycle that visits every city;
  • TS cycle if it is a cycle that visits every city, but not a simple cycle;
  • Not a TS cycle if it is NOT a cycle that visits every city.

Finally print in a line Shortest Dist(X) = TotalDist where X is the index of the cycle that is the closest to the solution of a travelling salesman problem, and TotalDist is its total distance. It is guaranteed that such a solution is unique.

Sample Input:

6 10
6 2 1
3 4 1
1 5 1
2 5 1
3 1 8
4 1 6
1 6 1
6 3 1
1 2 1
4 5 1
7
7 5 1 4 3 6 2 5
7 6 1 3 4 5 2 6
6 5 1 4 3 6 2
9 6 2 1 6 3 4 5 2 6
4 1 2 5 1
7 6 1 2 5 4 3 1
7 6 3 2 5 4 1 6

Sample Output:

Path 1: 11 (TS simple cycle)
Path 2: 13 (TS simple cycle)
Path 3: 10 (Not a TS cycle)
Path 4: 8 (TS cycle)
Path 5: 3 (Not a TS cycle)
Path 6: 13 (Not a TS cycle)
Path 7: NA (Not a TS cycle)
Shortest Dist(4) = 8

Ω

TSP是一个NP难问题,这一题需要你判断给定无向图中的一些路径是以下三种中的哪种:

  1. TS 简单环:每座城市访问过且仅访问过一次

  2. TS 环:每座城市都访问过,但部分城市多次 访问

  3. 非TS环:部分城市没有访问,或根本不是环,或路线不存在

注意如果不是路线不存在,所有的路线都需要输出总长度,而最优路线只能从TS simple cycle和TS cycle中选。用一个bitset<201>来标记城市是否访问过,用整型变量jdg的低两位分别来表示具备TS cycle(重复访问城市)和Not a TS cycle的特征(有城市没访问、不是环路、路线不存在),显然当 时说明是前者的情况,而 都是后者。读入路线的过程中,判断是否重复访问,同时检查路线是否存在。读完之后判断起点和终点是否相同,是否所有城市都已访问。最后根据jdg的值输出相应的信息。


🐎

#include <iostream>
#include <vector>
#include <bitset>

using namespace std;

int main()
{
    int n, m, k, a, b, p, d = 0, jdg = 0, opt = -1, min_d = INT32_MAX;
    cin >> n >> m;
    vector<vector<int>> dist(n + 1, vector(n + 1, 0));
    for (int i = 0; i < m; ++i)
        cin >> a >> b >> dist[b][a], dist[a][b] = dist[b][a];
    cin >> m;
    for (int i = 0; i < m; ++i, d = 0, jdg = 0)
    {
        bitset<201> flag(string(n, '1'));
        cin >> k >> a, p = a;
        for (int j = 1; j < k; ++j, p = b)
        {
            cin >> b;
            // if revisit city and visit non-existent road
            jdg |= !flag[b - 1] + (dist[p][b] ? 0 : (d = -1, 2));
            d += (d > -1) * dist[p][b], flag[b - 1] = false;
        }
        // if starting city is same as ending city and all the cities have been visited
        jdg |= (a == b && flag == 0 ? 0 : 2);
        switch (jdg)
        {
            case 0:
                printf("Path %d: %d (TS simple cycle)\n", i + 1, d);
                if (d < min_d) min_d = d, opt = i + 1;
                break;
            case 1:
                printf("Path %d: %d (TS cycle)\n", i + 1, d);
                if (d < min_d) min_d = d, opt = i + 1;
                break;
            default:
                if (d > 0) printf("Path %d: %d (Not a TS cycle)\n", i + 1, d);
                else printf("Path %d: NA (Not a TS cycle)\n", i + 1);
                break;
        }
    }
    printf("Shortest Dist(%d) = %d", opt, min_d);
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值