1150 Travelling Salesman Problem (25point(s)) - C语言 PAT 甲级

1150 Travelling Salesman Problem (25point(s))

The “travelling salesman problem” asks the following question: “Given a list of cities and the distances between each pair of cities, what is the shortest possible route that visits each city and returns to the origin city?” It is an NP-hard problem in combinatorial optimization, important in operations research and theoretical computer science. (Quoted from “https://en.wikipedia.org/wiki/Travelling_salesman_problem”.)

In this problem, you are supposed to find, from a given list of cycles, the one that is the closest to the solution of a travelling salesman problem.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (2<N≤200), the number of cities, and M, the number of edges in an undirected graph. Then M lines follow, each describes an edge in the format City1 City2 Dist, where the cities are numbered from 1 to N and the distance Dist is positive and is no more than 100. The next line gives a positive integer K which is the number of paths, followed by K lines of paths, each in the format:

n C​1​​ C​2​​ … C​n​​

where n is the number of cities in the list, and C​i​​’s are the cities on a path.

Output Specification:

For each path, print in a line Path X: TotalDist (Description) where X is the index (starting from 1) of that path, TotalDist its total distance (if this distance does not exist, output NA instead), and Description is one of the following:

  • TS simple cycle if it is a simple cycle that visits every city;
  • TS cycle if it is a cycle that visits every city, but not a simple cycle;
  • Not a TS cycle if it is NOT a cycle that visits every city.

Finally print in a line Shortest Dist(X) = TotalDist where X is the index of the cycle that is the closest to the solution of a travelling salesman problem, and TotalDist is its total distance. It is guaranteed that such a solution is unique.

Sample Input:

6 10
6 2 1
3 4 1
1 5 1
2 5 1
3 1 8
4 1 6
1 6 1
6 3 1
1 2 1
4 5 1
7
7 5 1 4 3 6 2 5
7 6 1 3 4 5 2 6
6 5 1 4 3 6 2
9 6 2 1 6 3 4 5 2 6
4 1 2 5 1
7 6 1 2 5 4 3 1
7 6 3 2 5 4 1 6

Sample Output:

Path 1: 11 (TS simple cycle)
Path 2: 13 (TS simple cycle)
Path 3: 10 (Not a TS cycle)
Path 4: 8 (TS cycle)
Path 5: 3 (Not a TS cycle)
Path 6: 13 (Not a TS cycle)
Path 7: NA (Not a TS cycle)
Shortest Dist(4) = 8

题目大意:

输入 N 个节点,M 条边的无向图,K 条路径查询,并给出每条路径的节点个数 n 和 n 个节点,判断每条路径是否为以下路径:

  • TS simple cycle:遍历了图中所有节点的简单环
  • TS cycle:遍历了图中所有节点的环
  • Not a TS cycle:既不是 TS simple cycle 也不是 TS cycle

输出每条路径的判断结果

  • cycle:环是指从起点沿着路径能回到起点
  • simple cycle:是个环,而且除了首尾节点相同外,其他节点均不相同
设计思路:
  • 判断是否是 cycle,能否构成回路
  • 判读是否是 simple cycle,构成的回路,仅首尾节点相同
  • 判断是否是 TS,路径节点个数等于图节点个数 N + 1,因为首尾节点均是起点
编译器:C (gcc)
#include <stdio.h>
#include <limits.h>

int main(void)
{
        int n, m, k;
        int v[210][210] = {0};
        int minindex = -1, mindis = INT_MAX;
        int a, b, c, i, j;

        scanf("%d %d", &n, &m);
        for (i = 0; i < m; i++) {
                scanf("%d %d %d", &a, &b, &c);
                v[a][b] = v[b][a] = c;
        }
        scanf("%d", &k);
        int p[2010], t, dis, cycle, simple, na;
        int map[210], cnt;
        for (j = 1; j <= k; j++) {
                for (i = 0; i < 210; i++)
                        map[i] = 0;
                cnt = 0;
                dis = 0;
                cycle = 1;
                simple = 1;
                na = 0;
                scanf("%d", &t);
                for (i = 0; i < t; i++) {
                        scanf("%d", &p[i]);
                        if (i > 0) {
                                na = (v[p[i - 1]][p[i]] == 0 ? 1 : na);
                                dis += v[p[i - 1]][p[i]];
                                if (map[p[i]] == 0) {
                                        map[p[i]] = 1;
                                        cnt++;
                                }
                        }
                }
                cycle = (na == 0 && p[0] == p[t - 1] && cnt == n);
                if (cycle == 1 && t == n + 1)
                        simple = 1;
                else
                        simple = 0;

                printf("Path %d: ", j);
                if (na)
                        printf("NA");
                else
                        printf("%d", dis);
                printf(" (%s)\n", cycle ? (simple ? ("TS simple cycle") : ("TS cycle")) : ("Not a TS cycle"));
                if (cycle && dis < mindis) {
                        mindis = dis;
                        minindex = j;
                }
        }
        printf("Shortest Dist(%d) = %d", minindex, mindis);
        return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值