1114 Family Property (25 分)

1114 Family Property (25 分)

This time, you are supposed to help us collect the data for family-owned property. Given each person's family members, and the estate(房产)info under his/her own name, we need to know the size of each family, and the average area and number of sets of their real estate.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer NNN (≤1000\le 1000≤1000). Then NNN lines follow, each gives the infomation of a person who owns estate in the format:

ID Father Mother kkk Child1⋯ChildkChild_1 \cdots Child_kChild​1​​⋯Child​k​​ MestateM_{estate}M​estate​​ Area

where ID is a unique 4-digit identification number for each person; Father and Mother are the ID's of this person's parents (if a parent has passed away, -1 will be given instead); kkk (0≤k≤50\le k\le 50≤k≤5) is the number of children of this person; ChildiChild_iChild​i​​'s are the ID's of his/her children; MestateM_{estate}M​estate​​ is the total number of sets of the real estate under his/her name; and Area is the total area of his/her estate.

Output Specification:

For each case, first print in a line the number of families (all the people that are related directly or indirectly are considered in the same family). Then output the family info in the format:

ID M AVGsetsAVG_{sets}AVG​sets​​ AVGareaAVG_{area}AVG​area​​

where ID is the smallest ID in the family; M is the total number of family members; AVGsetsAVG_{sets}AVG​sets​​ is the average number of sets of their real estate; and AVGareaAVG_{area}AVG​area​​ is the average area. The average numbers must be accurate up to 3 decimal places. The families must be given in descending order of their average areas, and in ascending order of the ID's if there is a tie.

Sample Input:

10
6666 5551 5552 1 7777 1 100
1234 5678 9012 1 0002 2 300
8888 -1 -1 0 1 1000
2468 0001 0004 1 2222 1 500
7777 6666 -1 0 2 300
3721 -1 -1 1 2333 2 150
9012 -1 -1 3 1236 1235 1234 1 100
1235 5678 9012 0 1 50
2222 1236 2468 2 6661 6662 1 300
2333 -1 3721 3 6661 6662 6663 1 100

Sample Output:

3
8888 1 1.000 1000.000
0001 15 0.600 100.000
5551 4 0.750 100.000
#include<iostream>
#include<cstring>
#include<vector>
#include<map>
#include<algorithm>
using namespace std;
int f[10003];
struct node{
	int id,fid,mid,num,area;
	int cid[6];
};
struct node a[10002];
struct recorder{
	int id,people;
	double num,area; //房产数,房产面积 
	bool flag = false;
};
struct recorder b[10003];
int book[10003]={0};
int getf(int x){
	while(x != f[x]){
		x = f[x];
	}
	return x;
}
void merge(int x,int y){
	int t1 = getf(x);
	int t2 = getf(y);
	if(t1 > t2){
		f[t1] = t2;
	}else{
		f[t2] = t1;
	}
}
int cnt = 0;
int cmp(recorder x,recorder y){
	if(x.area!=y.area)
		return x.area > y.area;
	else{
		return x.id < y.id;
	}
}
int main(){
	int n,k;
	cin >> n;
	for(int i = 0;i < 10002;i++){
		f[i] = i;
	}
	for(int i = 0;i < n;i++){
		cin >> a[i].id >> a[i].fid >> a[i].mid >> k;
		book[a[i].id] = 1;
		if(a[i].fid != -1){
			book[a[i].fid] = 1;
			merge(a[i].fid,a[i].id);
		}
		if(a[i].mid != -1){
			book[a[i].mid] = 1;
			merge(a[i].mid,a[i].id);
		}
		for(int j = 0;j < k;j++){
			cin >> a[i].cid[j];
			book[a[i].cid[j]] = 1;
			merge(a[i].cid[j],a[i].id);
		}
		cin >> a[i].num >> a[i].area;
	}
	for(int i = 0;i < n;i++){
		int id = getf(f[a[i].id]);
		b[id].id = id;
		b[id].num += a[i].num; //房产数 
		b[id].area += a[i].area;//房产面积 
		b[id].flag = 1; //每个家庭最小的那个标记为1 
	}
	for(int i = 0;i < 10000;i++){
		if(book[i]){  //每个家庭的人数 
			b[getf(i)].people++;
		}
		if(b[i].flag){ //家庭数目 
			cnt++;
		}
	}
	for(int i = 0;i < 10000;i++){
		if(b[i].flag){
			b[i].num = (double)(b[i].num*1.0/b[i].people);
			b[i].area = (double)(b[i].area*1.0/b[i].people);
		}
	}
	sort(b,b+10000,cmp);
	cout << cnt << endl;
	for(int i = 0;i < cnt;i++){
		printf("%04d %d %.3f %.3f\n",b[i].id,b[i].people,b[i].num,b[i].area);
	}
	return 0;
	
} 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值