1114 Family Property(25 分)(C++)

This time, you are supposed to help us collect the data for family-owned property. Given each person's family members, and the estate(房产)info under his/her own name, we need to know the size of each family, and the average area and number of sets of their real estate.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤1000). Then N lines follow, each gives the infomation of a person who owns estate in the format:

ID Father Mother k Child​1​​⋯Child​k​​ M​estate​​ Area

where ID is a unique 4-digit identification number for each person; Father and Mother are the ID's of this person's parents (if a parent has passed away, -1will be given instead); k (0≤k≤5) is the number of children of this person; Child​i​​'s are the ID's of his/her children; M​estate​​ is the total number of sets of the real estate under his/her name; and Area is the total area of his/her estate.

Output Specification:

For each case, first print in a line the number of families (all the people that are related directly or indirectly are considered in the same family). Then output the family info in the format:

ID M AVG​sets​​ AVG​area​​

where ID is the smallest ID in the family; M is the total number of family members; AVG​sets​​ is the average number of sets of their real estate; and AVG​area​​ is the average area. The average numbers must be accurate up to 3 decimal places. The families must be given in descending order of their average areas, and in ascending order of the ID's if there is a tie.

Sample Input:

10
6666 5551 5552 1 7777 1 100
1234 5678 9012 1 0002 2 300
8888 -1 -1 0 1 1000
2468 0001 0004 1 2222 1 500
7777 6666 -1 0 2 300
3721 -1 -1 1 2333 2 150
9012 -1 -1 3 1236 1235 1234 1 100
1235 5678 9012 0 1 50
2222 1236 2468 2 6661 6662 1 300
2333 -1 3721 3 6661 6662 6663 1 100

Sample Output:

3
8888 1 1.000 1000.000
0001 15 0.600 100.000
5551 4 0.750 100.000

知识点:并查集

PAT中并查集的题大概有3-4道的样子,这题应该是里面难度较大的一题,因为有两个参数,某些地方处理起来确实麻烦了点。

关键点:每个群落首领的选取,题目要求的是选取ID最小的作为首领,Union中的最终father选取小一点的

另外计算estate平均数的时候记得先将原来的数转换float

#include <iostream>
#include <vector>
#include <algorithm>
#include <set>
using namespace std;
vector<int>father(10005),estate(10005,0),cnt(10005,1);
std::vector<double> area(10005,0);
std::vector<int> ans;
bool visit[10005];
set<int>s;
int findfather(int x){
    int a = x;
    while(x != father[x])
        x = father[x];
    while(a != x){
        int z = a;
        a = father[a];
        father[z] = x;
    }
    return x;
}
void Union(int a, int b){
    if(b == -1)
        return;
    visit[b] = true;
    int faa = findfather(a), fab = findfather(b);
    if(faa > fab)
        swap(faa,fab);
    father[fab] = faa;
}
int cmp(int a, int b){
    return area[a] != area[b] ? area[a] > area[b] : a < b;
}
int main(){
    int n;
    cin>>n;
    for(int i = 0; i < 10005; i++)
        father[i] = i;
    for(int i = 0; i < n; i++){
        int id, id_father, id_mother, k, child;
        scanf("%d %d %d %d", &id, &id_father, &id_mother, &k);
        visit[id] = true; 
        Union(id,id_father);
        Union(id,id_mother);
        for(int j = 0; j < k; j++){
            scanf("%d",&child);
            Union(id,child);
        }
        scanf("%d %lf",&estate[id],&area[id]);
    }
    for(int i = 0; i < 10005; i ++){
        if(visit[i] == false)
            continue;
        int fa = findfather(i);
        if(s.find(fa) == s.end()){
            ans.push_back(fa);
            s.insert(fa);
        }
        if(fa != i){
            cnt[fa]++;
            estate[fa] += estate[i];
            area[fa] += area[i];
        }
    }
    for(int i = 0; i < ans.size(); i++)
        area[ans[i]] = 1.0 * area[ans[i]] / cnt[ans[i]];
    sort(ans.begin(), ans.end(),cmp);
    printf("%d",ans.size());
    for(int i = 0; i < ans.size(); i++)
        printf("\n%04d %d %.3f %.3f",ans[i],cnt[ans[i]],(1.0 * estate[ans[i]])/cnt[ans[i]],area[ans[i]]);
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值