数据结构实验之二叉树四:(先序中序)还原二叉树

32 篇文章 0 订阅
6 篇文章 0 订阅

Problem Description
给定一棵二叉树的先序遍历序列和中序遍历序列,要求计算该二叉树的高度。

Input
输入数据有多组,每组数据第一行输入1个正整数N(1 <= N <= 50)为树中结点总数,随后2行先后给出先序和中序遍历序列,均是长度为N的不包含重复英文字母(区分大小写)的字符串。

Output
输出一个整数,即该二叉树的高度。

Sample Input
9
ABDFGHIEC
FDHGIBEAC
Sample Output
5

#include <iostream>
#include <cstdlib>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <map>
#include <stack>
#include <queue>
#include <cmath>
#define INF 0x3f3f3f3f
using namespace std;
struct node
{
    int data;
    struct node *l;
    struct node *r;
};
struct node *create(int n,int a[],int b[])
{
    struct node *root = NULL;
    if(n==0)
        return NULL;
    else
    {
        root = (struct node *)malloc(sizeof(struct node));
        root->data = b[n-1];
        int j = 0;
        for(int i=0;i<n;i++)
        {
            if(a[i]==b[n-1])
            {
                j = i;
                break;
            }
        }
        root->l = create(j,a,b);
        root->r = create(n-j-1,a+j+1,b+j);
    }
    return root;
}
void ceng(struct node *root)
{
    struct node *temp[60];
    int in = 0;
    int out = 0;
    int c[60];
    int j = 0;
    temp[in++] = root;
    while(in>out)
    {
        if(temp[out])
        {
            c[j++] = temp[out]->data;
            ///一定要注意这里,以前没有遇到过这种情况,如果用数组模拟的话,需要开两倍的空间。
            ///因为叶子结点也符合条件,所以叶子结点的孩子虽然为空,但是也要入队列。
            ///所以需要多n+1个空间。
            temp[in++] = temp[out]->l;
            temp[in++] = temp[out]->r;
        }
        out++;
    }
    for(int i=0;i<j;i++)
        printf(i==j-1?"%d\n":"%d ",c[i]);
}
int main()
{
    int n;
    int a[550];
    int b[550];
    struct node *root = NULL;
    scanf("%d",&n);
    for(int i=0;i<n;i++)
        scanf("%d",&b[i]);
    for(int i=0;i<n;i++)
        scanf("%d",&a[i]);
    root = create(n,a,b);
    if(root)
        ceng(root);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值