7-23 还原二叉树 (25 分)(分析加详解)

一:题目:

给定一棵二叉树的先序遍历序列和中序遍历序列,要求计算该二叉树的高度。

输入格式:
输入首先给出正整数N(≤50),为树中结点总数。下面两行先后给出先序和中序遍历序列,均是长度为N的不包含重复英文字母(区别大小写)的字符串。

输出格式:
输出为一个整数,即该二叉树的高度。

输入样例:
9
ABDFGHIEC
FDHGIBEAC
输出样例:
5

二:思路

利用前序和中序进行建树,然后求取二叉树的高度

三:上马

/*
思路:根据中序和前序进行建树  然后求的树的高度 
*/ 
#include<bits/stdc++.h>
using namespace std;

typedef struct TNode* Bintree;
typedef struct TNode{
    char Date;
    Bintree left,right;
}tnode;

Bintree CreatBintree(string s1,string s2,int prel,int prer,int inl,int inr)
{
    if(prel > prer)
    {
    	return NULL;
	}
    

    Bintree BT = (Bintree)malloc(sizeof(struct TNode));
    BT->Date = s1[prel];
    BT->left = NULL;
	BT->right = NULL;

//	cout << s1[prel];

    int temp; 
    for( int i = inl; i <= inr; i++ )
    {
        if( s2[i] == s1[prel])
        {
            temp = i;
            break;
        }
    }

    int numleft = temp - inl;//求出左子树上的结点数目

    BT->left = CreatBintree(s1,s2,prel+1,prel + numleft,inl,temp-1);
    BT->right = CreatBintree(s1,s2,prel+numleft + 1,prer,temp+1,inr);
    
    return BT;

}

int treehight(Bintree Bt)
{
	if(Bt == NULL)
	return 0;
	
	int m,n;
	m = treehight(Bt->left) +1;
	n = treehight(Bt->right) +1;
	
	return m > n? m:n;
}

int main(){

    int N;
    string str1,str2;
    cin >> N >> str1 >> str2;

    Bintree Bt = CreatBintree(str1,str2,0,N-1,0,N-1);
	//houxv(Bt);

    int cnt = treehight(Bt);
    cout << cnt;



}

在这里插入图片描述

总结:

这种题做了三遍了,核心递归建树那部分真的难 参数稍微错一点 就会 出现访问越界问题 ,用本题给的示例,进行找规律 不好,最好自己找一个左右子树结点个数差不多的二叉树 来找规律,我是拿笔在纸上自己递归几遍 ,就这样一点点找规律。
加油陌生的你!

  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

天天向上的菜鸡杰!!

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值