Dividing(多重背包)

Description

Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value. 
Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles. 
 

Input

Each line in the input describes one collection of marbles to be divided. The lines consist of six non-negative integers n1, n2, ..., n6, where ni is the number of marbles of value i. So, the example from above would be described by the input-line ``1 0 1 2 0 0''. The maximum total number of marbles will be 20000. 

The last line of the input file will be ``0 0 0 0 0 0''; do not process this line. 
 

Output

For each colletcion, output ``Collection #k:'', where k is the number of the test case, and then either ``Can be divided.'' or ``Can't be divided.''. 

Output a blank line after each test case. 
 

Sample Input

 
    
1 0 1 2 0 01 0 0 0 1 10 0 0 0 0 0
 

Sample Output

 
    
Collection #1:Can't be divided.Collection #2:Can be divided.

题意:i价值的石头有a[i]个,现两人平分石头,问是否能分得相同的总价值;

以价值为背包容量,如果能平分,则总价值为偶数,且满足dp[sum/2]=sum/2;

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<cmath>
#include<queue>
#include<stack>
using namespace std;
const int MAXN=20000+9;
const int MAXM=50+9;
const int inf=0x3f3f;
int dp[6*MAXN],a[MAXN],t;
void zeroone(int ci,int wi)
{
    for(int i=t;i>=ci;i--)
    {
        dp[i]=max(dp[i],dp[i-ci]+wi);
    }
}
void complete(int ci,int wi)
{
    for(int i=ci;i<=t;i++)
    {
        dp[i]=max(dp[i],dp[i-ci]+wi);
    }
}
void multiple(int ci,int wi,int amount)
{
    if(ci*amount<t)//只用该物品不能将背包放满,不能将该物品看做是无限个,则用01背包
    {
        for(int i=1;i<amount;i<<=1)//二进制优化,例如该物品13个,则分成1,2,4,6,即1,2,4,...,2^(k-1),n[i]-2^k+1,且k是满足n[i]-2^k+1>0的最大整数
        {
            zeroone(ci*i,wi*i);
            amount-=i;
        }
        zeroone(amount*ci,amount*wi);
    }
    else//只用该物品能将背包放满,能将该物品看做是无限个,则用完全背包
    {
        complete(ci,wi);
    }
}
int main()
{
    int p=0;
    int a[10];
    while(~scanf("%d",&a[0]))
    {
        int ans=0;
        if(!a[0]) ans++;
        memset(dp,0,sizeof(dp));
        int k=0,sum=0;
        for(int i=0; i<6; i++)
        {
            if(i)
            {
                scanf("%d",&a[i]);
                if(!a[i])
                {
                    ans++;
                }
            }
            for(int j=1; j<=a[i]; j++)
            {
                sum+=i+1;
            }
        }
        if(ans==6) break;
        if(sum%2)
        {
            printf("Collection #%d:\nCan't be divided.\n\n",++p);
            continue;
        }
        t=sum/2;
        for(int i=0;i<6;i++)
        {
            multiple(i+1,i+1,a[i]);
        }
        if(dp[t]==t) printf("Collection #%d:\nCan be divided.\n\n",++p);
        else printf("Collection #%d:\nCan't be divided.\n\n",++p);
    }
    return 0;
}

 
 
 
 



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值